My computer is running Debian Linux and is having a problem starting up. After I select the OS from the GRUB bootloader, I see messages for the drivers being loaded then I get a completely pixelated screen and getting stuck there. I have not installed any new hardware. What could be causing this?

EDITED: Here is a video of the boot process: http://youtu.be/NutfywloGO0

EDITED: Here is a screenshot of the pixelated screen. Could it be that the resolution is out of limits? How could I edit that if that is the case.


  • Have you tried selecting the rescue option off the boot menu?
    – Zoredache
    May 2, 2012 at 20:06
  • @Zoredache Yes, it is also ending up in a pixelated screen. In fact I was not able to get the server to restart when selecting recovery mode.
    – Omtara
    May 2, 2012 at 20:18
  • Note: The server is within a hosting company's environment and I am using a KVM client to connect to it remotely.
    – Omtara
    May 2, 2012 at 20:19
  • this is a headless server yes, x is not installed correct? it's fubar. get the hardrive(s) put into another machine. May 2, 2012 at 21:08
  • Can you please add a picture of the "pixelated screen"? May 2, 2012 at 22:07

5 Answers 5


Can the server boot in single user mode? If yes, the problem is in a daemon contained in /etc/rc2.d/. If no, the problem is before in boot process.


Use "Ctrl+Alt+F2 or F3" , you should see the text console of the boot process. The last started process or status should lead you to the correct solution.

  • I am seeing the text console of the boot process without pressing any key. But when the boot process is over, I am getting the pixelated screen.
    – Omtara
    May 2, 2012 at 20:27
  • What is the last process its completed ?
    – Chakri
    May 2, 2012 at 21:09

If it's a graphic card problem, you may activate serial console and access to your server from your pc using a serial cable.


I had the same problem once, when the grub splash file was corrupted or not available. Could you check that? Please also post you full grub config and partition layout.


This is a hardware or driver problem.

If you expect to be a driver problem, try to boot with a LiveCD. If it is working try to configure the Debian kernel to use VGA or try noapic, acpi=off etc. Try to boot with a different kernel.

If you expect to be a hardware problem, then check the following components in this order:

  • VGA card - by replacing it with a good one
  • memory - run a memory test from the BIOS of the server, run a memory test suite like memtest86+
  • power supply - replace with a good one
  • motherboard - replace with a good one
  • CPU - run a CPU test from a LiveCD

Switching cards around could fix the problem if you have a IRQ sharing an a broken driver.


From the video I can see that you are starting X. You do not need this on a server. Try to disable it. Change in the /etc/inittab the initdefault line from 5 to 2:

  • Did you see the video I posted?
    – Omtara
    May 3, 2012 at 14:28
  • Can you add vga=ask as a boot parameter? This will ask for videomode. Try each one and see which is workin and then replace vga=ask with vga=### where ### is the mode that works. May 3, 2012 at 15:33
  • Also remove any splash option in grub May 3, 2012 at 15:35
  • vga=ask is not working. I am getting a message saying that the legacy 'ask' parameter is no longer supported. For disabling X, is there any text editor in GRUB? The shell provided by GRUB is very limited.
    – Omtara
    May 5, 2012 at 13:01
  • You have to boot in single user mode to be able to edit /etc/inittab, or to boot from a CD May 5, 2012 at 13:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .