We'd like a convenient path for users to access TFS: http://tfs.company.com/.

We made a new entry in DNS, then created a new IP on the machine, and then set up a binding to the Team Foundation Server IIS web site to the new IP. This works okay, but in order to access tfs we have to go to http://tfs.company.com/tfs/.

I'd like to remove the extra "tfs" at the end, but can't seem to do it!


I am pretty sure that the virtual directory in TFS is a configurable option. If you're up for it, maybe try reinstalling TFS, but this time don't use the v-dir. Then map the DNS name to the new server.

  • 1
    I prefer to setup a redirect to the vDir and leave it there to stick with convention because there may be other tools or services that hit it that way; also, when users search online for how to connect, etc... following the conventional approach will make it more clear to them about what to do; if the vDir isn't there it might confuse people. – Ryan Riehle Jun 17 '14 at 15:10

do a redirect from the root of the site to /tfs. You can do this in IIS pretty easily. If a user hits it on http://tfs.company.com/ , their browser will redirect to the sub application /tfs without having to do anything. Remember to use SSL on the internets :) if this is going to be a public web site. If it's internal, no worries. Good luck!

  • Thanks for the reply. That's the first thing I tried, setting up an HTTP Redirect for that site to the sub folder. But something strange happened when I tested it. Instead of working properly it forwarded to ww35.tfs.compnay.com. "company" was misspelled and ww35 was prepended. I triple checked that I didn't make any misspellings in the redirect. I am assuming that our IT Director has some mistake in a DNS entry somewhere but I don't know where to tell him to look. – msigman May 4 '12 at 12:48
  • Sounds like you may be in a server farm or something like that. That behaviour you describe is not normal - so yeah - your IT director will need to take a look - sounds like they have something screwed up internally. – James May 4 '12 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.