2
votes

I installed CentOS 6.2 (CentOS-6.2-x86_64-minimal.iso) with VMWare Fusion(Version 4.1.2). (Not with EasyInstall). I am using MacOSX Lion, connect to internet via WIFI.

The centos installed does not have network connectivity. **How may I configure it to connect to wifi? **

Thanks for any help.

Below is screenshot of ifconfig: enter image description here

With the setting Network Adapter, I tried both NAT and Bridged > WiFi.

enter image description here

4
votes

Did you install the VMWare Tools on the CentOS guest? If not, try that and restart the VM.

A quick check to see if any device is configured would be to run ifconfig -a, which will show all interfaces on the system.

If an eth0 is displayed in that output, you may have an issue with interface auto-configuration. This is possibly a result of the Network Manager service... If eth0 shows up, you have several options:

  • Run ifup eth0 to try to bring the connection online.
  • Run system-config-network to configure the interface.
  • Configure the interface manually at /etc/sysconfig/network-scripts/ifcfg-eth0.

Let us know what you see, though.

  • What should I select for Network Adapter setting? the 2nd screenshot in my question, which option to pick? – gilzero May 4 '12 at 11:50
  • That doesn't matter. You're not seeing any interfaces within the guest yet. – ewwhite May 4 '12 at 11:53
  • thank you. i got it work after editing /etc/sysconfig/network-scripts/ifcfg-eth0 – gilzero May 4 '12 at 12:02
2
votes

Ah. CentOS6 doesn't connect the eth interfaces by default.

Create this file: /etc/sysconfig/network-scripts/ifcfg-eth0 containing these lines

DEVICE="eth0"
ONBOOT="yes"
BOOTPROTO="dhcp"

...and restart your networking with 'sudo service network restart' and your eth should pull an IP via DHCP.

If you wish to set a static IP you can add IPADDR and NETMASK settings in this file, but I have not done that so experimenting with the syntax is left as an exercise for you.

1
vote

ifconfig returns only the properly configured network interfaces. Type

ifconfig -a 

You will probably find a network interface that is not configured. Configure it manually by editing the file /etc/sysconfig/network-scripts/iface-ethx

Replace ethx in the vile name by the name of the interface you found with ifconfig -a

1
vote

I tried and came to the same result.

My diagnostics : the minimal iso lacks the tools to finish a proper vmware installation. As it is, it doesn't recognize the vmware emulated hardware layer and does not install the software (perl, make, gcc) necessary to install vmware tools.

So i think we're stuck here : no network to fetch the software needed to install vmware tools and no vmware driver to get network...

1
vote
  1. Install your VMWare tool.

  2. Restart your machine and check if your vmtool is running. (ps aux | grep vmware)

  3. go to the configuration /etc/sysconfig/networking/devices/ifcfg-eth0 and comment the following lines.

   #NM_CONTROLLED=yes

   #USERCTL=no

   #PEERDNS=yes

   #IPV6INIT=no

4) and change ONBOOT=yes

5) save the file and restart the network service (service network restart) and do one final reboot.

6) ifconfig --> should display the eth0 with IP address assigned.

This completely worked for me :-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.