0

I've got an ASP.NET JSON-RPC web service which work well using the Visual Studio development web server. It has three dependencies: Jayrock, Log4net and a COM DLL (AcoSDK) to be able to access a C++ application.

I'm trying to deploy it on IIS7 in a SBS 2008 server, but I'm having lots of troubles. The application files are in "C:\intepub\wwwroot\AcombaConnect_Deploy" include the bin folder with the compiled binaries. The folder has been converted to an application, but the application would not start so I had to add the following section to the Web.config file:

<system.webServer>
  <handlers>
    <add name="AcombaConnect.Acomba" verb="*" path="*" scriptProcessor="C:\\Windows\\Microsoft.NET\\Framework\\v4.0.30319\\aspnet_isapi.dll" type="AcombaConnect.Acomba, AcombaConnect" resourceType="Unspecified"/>
  </handlers>
  <directoryBrowse enabled="false"/>
</system.webServer>

At that point the app was throwing: "bad module "ManagedPipelineHandler" in its module list" and I've tried everything from https://stackoverflow.com/questions/8659862 to no avail. I then tried to switch the application pool to the integrated one and added the following to the Web.config file:

<system.webServer>
  <validation validateIntegratedModeConfiguration="false"/>
  ...

Now, it seems the application is starting, but I only get "HTTP Error 503. The service is unavailable."

Does anybody know where to go from there?

P.S.: I don't have much experience with IIS7. I'm not sure where to look for more detailed error messages.

1

You should open Event Viewer to see if any interesting errors have been logged there. Anything related to your site should show up under "Administrative Events" with "ASP.NET [version]" or ".NET Runtime" as the source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.