6

I am not sure where to ask this question but I'll ask here first.

I've got a Synology DS211 server and I am trying to run cron jobs but it is not working.

This is the code I got in the crontab file

10 19 4 * * root /opt/bin/openssh-scp user@remote-server:/home/user/Backup/backup.tar.gz /volume1/Backup/ 

However it is not running.

I am able to run commands with /opt/bin/openssh-scp directly, but not with cron

Is there anything I am doing wrong?

2
  • If this command prompts your for a password, it will not work as cron job. Is this the case?
    – Khaled
    Commented May 7, 2012 at 10:13
  • It does not require a password, public key installed on remote-server
    – zentenk
    Commented May 7, 2012 at 11:15

4 Answers 4

1

I've got cronjobs working on our DS1010+. In order to do this I had to add the jobs to /etc/crontab and then run /usr/syno/etc.defaults/rc.d/S04crond.sh stop followed by /usr/syno/etc.defaults/rc.d/S04crond.sh start

Instead of running those last 2 commands you can just reboot the NAS instead. As Khaled says you'll also need to make sure that you have keys set up so that you don't need to enter a password for the SCP.

2
  • 1
    I have already tried restarting the service using synoservice --restart crond and have also tried restarting the NAS. It still does not work.
    – zentenk
    Commented May 7, 2012 at 11:16
  • In that case I'm out of ideas, sorry.
    – Phil
    Commented May 7, 2012 at 11:36
1

You need to use "tabs" to separate the entries not spaces.

2
0

I don't know if this is an option for you, but the Synology DSM software (versions 4.2 and up) includes a task scheduler feature. For all I know it may simply be converting it to a crontab job under the covers, but perhaps trying it out from the admin GUI may get the job done and help avoid any syntax issues.

-1

DS211 using CHIP MV6282 so you can install bootstrap and then install ipkg, then install crond. This crond work well like any other linux, unix systems.

Do not use the default crontab of synology DSM.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .