I want to add a 12TB NAS to my current iSCSI, which already controls an Iomega StorCenter ix2-200 1TB NAS.

I've connected to the new NAS via Windows 7 iSCSI Initiator. When I open Disk Manager it wants to initialize Disk2 Unknown, but when I tell to (doesn't matter if MBR or GPT) an error comes up "The drive cannot find the sector requested."

I apparently left out a step somewhere along the way, but I've backtracked numerous times and can't find anything missing.

Any ideas.


It's probably seeing the LUN through two paths- could be two ports on the storage device. You'd want to use some sort of multi-pathing driver like MPIO, but I've only ever seen it running on server OSes, never desktop.

| improve this answer | |
  • I've since watched a video about how to set up iSCSI link and have done everything up to 8:14 in the video. My Disk3 had Unknown under it. When it tell it to Initialize Disk3 using GPT (because they are 3TB disks) a Virtual Disk Manager error pops up - "The drive cannot find the sector requested." Are there any options to correct this issue? – Hammer1 May 14 '12 at 15:41
  • I can't watch videos at work, but did any of the steps up to that point include configuring a multipath driver like MPIO? – Basil May 14 '12 at 16:01
  • I didn't see anything. So, no. – Hammer1 May 14 '12 at 16:48
  • You need to have a multipath driver configured in order to only see the disk once. Windows uses MPIO, but I doubt it's supported on their desktop line. – Basil May 14 '12 at 17:11
  • What's frustrating is I already have an Iomega ix2-200 initiated on the iSCSI machine, but this one won't cooperate. – Hammer1 May 14 '12 at 17:16

The issue is that the server has recognized your device from previous attempts to configure the iSCSI. Your solution is to clear out all references from the iSCSI app and from the registry. Afterwards create your targets and devices with different names.

Works on Seagate BlackArmor NAS 400 with 3 x 3TB hard drives

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.