1

System has CentOS 6.2 32-bit installed. Im having some issues running 'yum update' - I get a series of errors that point to incorrect RPMs being installed (see this link: http://www.centos.org/modules/newbb/print.php?form=1&topic_id=34994&forum=56&order=ASC&start=0 )

[root@orange yum]# yum update
Finished Dependency Resolution
Error: Package: python-paramiko-1.7.6-1.el5.rf.noarch (rpmforge)
Requires: python(abi) = 2.4
Installed: python-2.6.6-29.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)
python(abi) = 2.6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I was following the thread and entered this cmd: rpm -qa | fgrep .el5 | less and found a number of entries.

[root@orange ~]# rpm -qa | grep .el5 | sort
fping-3.1-1.el5.rf.i386
hwloc-1.3-1.el5.rf.i386
libedit-20090923-3.0_1.el5.rf.i386
libffi-3.0.9-1.el5.rf.i386
libssh2-1.2.7-1.el5.rf.i386
nagios-nrpe-2.12-1.el5.rf.i386
nagios-plugins-1.4.15-2.el5.rf.i386
perl-Compress-Raw-Bzip2-2.037-1.el5.rf.i386
perl-Compress-Raw-Zlib-2.037-1.el5.rf.i386
perl-Crypt-DES-2.05-3.2.el5.rf.i386
perl-Data-UUID-1.203-1.el5.rf.i386
perl-Log-Message-Simple-0.06-1.el5.rf.noarch
perl-Module-Build-0.3607-1.el5.rf.noarch
perl-Module-CoreList-2.25-1.el5.rf.noarch
perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch
perl-Test-Harness-3.22-1.el5.rf.noarch
perl-Test-Simple-0.98-1.el5.rf.noarch
perl-Time-Piece-1.20-1.el5.rf.i386
perl-YAML-0.72-1.el5.rf.noarch
portreserve-0.0.5-2.el5.rf.i386
powertop-1.13-1.el5.rf.i386

My repositories:

[root@orange yum]# yum repolist
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: linux.mirrors.es.net
* extras: centos.mirror.facebook.net
* rpmforge: mirror.hmc.edu
* updates: mirrors.cat.pdx.edu
repo id repo name
base CentOS-6 - Base
extras CentOS-6 - Extras
rpmforge RHEL 6 - RPMforge.net - dag
updates CentOS-6 - Updates

So my questions are:
1) How did I end up with these rpms?
2) I've tried to 'yum erase <repo>' and then reinstall - I get the .el5 file again.

What am I doing wrong?

1 Answer 1

2

.rf. is telling you it's from RPMforge. Not sure why they would install but Yum figured they were compatible. Is there a problem with those packages or just yum update? I would disable RPMforge for the update. yum update --disablerepo=rpmforge. If the package exists in both repositories you will also end up with trouble.

5
  • That did it. So I don't need to be concerned with .el5 packages?
    – ethrbunny
    May 7, 2012 at 20:07
  • I wouldn't be overly concerned. It's compiled for EL5, but given the requirements no reason it shouldn't work for EL6 in many cases. Yum is way better at figuring that stuff out than we are. As long as the EL5 packages work as expected don't lose sleep over it. May 7, 2012 at 20:11
  • Something I didn't think about before: Is it possible the host was upgraded to CentOS 6? Rather than a clean install? May 7, 2012 at 20:12
  • No. Clean install.
    – ethrbunny
    May 8, 2012 at 14:29
  • There goes that theory. :) May 8, 2012 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .