I'm trying to install Z-threads on Ubuntu but am running into a problem. I've installed Z-threads dozens of times but this is the first time this has happened. I usually use these to install it:

wget http://voxel.dl.sourceforge.net/sourceforge/zthread/ZThread-2.3.2.tar.gz
tar -xzf ZThread-2.3.2.tar.gz
cd ZThread-2.3.2
./configure CXXFLAGS="-fpermissive" --prefix=/usr/
make && make install

It errors on the configure command above:

root@Rx:~/ZThread-2.3.2# ./configure CXXFLAGS="-fpermissive" --prefix=/usr/
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
Loading m4 macros from share
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking for linker option -pthread... no
checking for linker option -lpthread... yes
checking for sched_get_priority_max in -lrt... yes
checking for sched_yield... yes
checking for pthread_yield... yes
checking for pthread_key_create... yes
checking for doxygen... no
detecting for ftime() function
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for _ftime()... no
checking sys/timeb.h usability... yes
checking sys/timeb.h presence... yes
checking for sys/timeb.h... yes
checking for ftime()... yes
checking how to run the C++ preprocessor... g++ -E
checking for ANSI C header files... (cached) yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking for target implementation... compile-time guess
checking for sigsetjmp()... yes
checking for _beginthreadex()... no
checking for a sed that does not truncate output... /bin/sed
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking for correct ltmain.sh version... grep: character class syntax is [[:space:]], not [:space:]

*** Gentoo sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.10, ltmain.sh = ) ***

Please run:

  libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.


upon running libtoolize --copy --force :

root@Rx:~/ZThread-2.3.2# libtoolize --copy --force
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize:   `/usr/share/aclocal/libtool.m4'
libtoolize:   `/usr/share/aclocal/ltoptions.m4'
libtoolize:   `/usr/share/aclocal/ltversion.m4'
libtoolize:   `/usr/share/aclocal/ltsugar.m4'
libtoolize:   `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.

What is it even suggesting I do? And is it perhaps part of a larger problem?

  • gentoo. Ouch. You're on your own. – Tom O'Connor May 8 '12 at 21:44
  • Why? Is it because I'm running Ubuntu and it's a Gentoo error? – dukevin May 9 '12 at 4:01
  • It's very strange. Very strange indeed. – Tom O'Connor May 9 '12 at 7:41

I just installed ZThread on Ubuntu and posted how I worked around the issue at https://stackoverflow.com/a/33060825/4455221. Content of the answer is copied below as requested:

The reason that ltmain.sh has an empty version is because of a syntax error in the ./configure file. You should have the following error before *** Gentoo sanity check failed! ***:

checking for correct ltmain.sh version... grep: character class syntax is [[:space:]], not [:space:]

The error is in the following line of the ./configure file:

gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`

After changing [:space:] to [[:space:]], it becomes the following and should fix the issue:

gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`

It's likely that you will encounter a compilation error after this because of a deprecated syntax used by ZThread, which you can fix by adding the following line to ./configure:

CXXFLAGS="$CXXFLAGS -fpermissive"
  • We usually ask people to summarize the link in case of link rot. Could you expand your answer a little? – Katherine Villyard Oct 11 '15 at 12:55

If this is indeed and Ubuntu installation, and you're just logged in as root for fun.. (hint, you should always use sudo).

Why not just do sudo apt-get install libzthread-2.3-2 libzthread-dev and let the package management subsystem do the clever shit for you.

  • I am indeed on Ubuntu. The command you provided didn't fix the problem. I still get the same output as above for both zthreads and libtoolize – dukevin May 9 '12 at 8:43
  • 1
    I more meant that if you install libzthread then you don't need to build it from source, because you're using a package instead. – Tom O'Connor May 9 '12 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.