I am attempting to migrate a Windows 2008 R2 print server (queues, drivers et. al.) using printbrm. However, logged in as a domain admin, when trying to export, I keep getting the most frustrating and generic error from printbrm. Using the GUI or the Command Line, either with elevated privilege.

Log Name:      Application  
Source:        Microsoft-Windows-PrintBRM  
Date:          5/8/2012 10:18:52 AM  
Event ID:      57  
Task Category: (7)  
Level:         Error 
Keywords:      Classic  
User:          N/A  
Computer:      PRINT SERVER  
Printbrm.exe (the Printer Migration Wizard or the command-line tool) failed to place a file in cabinet (CAB) file FILE.printerExport while backing up print queues. Error reported: 0x80004005. Unspecified error
. This can occur if the user does not have permission to create a file in the destination location, or if there is insufficient disk space or system resources.
  • 1
    Try running it from an elevated command prompt. – joeqwerty May 8 '12 at 18:57
  • already done this, same error message – user95587 May 8 '12 at 19:17

Run the GUI as an administrator? I know that many times, even logging in as an admin won't cut it for windows. Right-click the GUI file/exe and select 'run as administrator.' Give password, and try from there.

edit: ok. here.
What is the size of the \windows\system32\spool\drivers directory on the machine you are backing up? If it's near 2gig you are hitting the max file size for cab formatted files

Source i found. looks like a very simlar problem, and an answer. good luck.

  • just tried this, same error message – user95587 May 8 '12 at 19:17
  • ok, editing answer w/ more info. – acolyte May 8 '12 at 19:22
  • now this sounds interesting - working.... Yup, my drivers directory is 2.9GB. Sounds like I need to work it down and try again. – user95587 May 8 '12 at 19:34
  • following the directions on the link, cleaning out \windows\system32\spool\drivers and deleting unused drivers with the print management tool, I pushed the size down to 1.8GB and prinbrm worked. Thanks!! – – user95587 May 8 '12 at 21:22
  • glad i could help! – acolyte May 9 '12 at 2:53

An update that improves the performance of the Printbrm.exe command-line tool in Windows 7 or in Windows Server 2008 R2 is available


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.