1
org.apache.subversion.javahl.ClientException: svn: E204900: Commit failed (details follow):
svn: E204900: Can't open file '/var/repo/db/txn-current-lock': Permission denied
svn: E175002: MKACTIVITY of '/var/repo/!svn/act/d0d4d437-3701-0010-ac67-11b5ce96094c//': 500 Internal Server Error (http://mywebsite.com)
org.apache.subversion.javahl.ClientException: svn: E204900: Commit failed (details follow):
svn: E204900: Can't open file '/var/repo/db/txn-current-lock': Permission denied
svn: E175002: MKACTIVITY of '/var/repo/!svn/act/d0d4d437-3701-0010-ac67-11b5ce96094c//': 500 Internal Server Error (http://mywebsite.com)

How can I bypass this short of making my /var/repo read-writeable by everyone? Do I just add the svn user to my group? (currently the folder is owned by jackson:web)

3 Answers 3

3

Check that the subversion repository (not your working copy) is writable by the user running svnserve (if your repository URL starts with svn://), the apache user (if your repository is accessed via http(s)) or your user (if you access the repository via ssh or locally).

Typically the svnserve daemon is running as the user svnserve. The apache user is either apache, httpd or www-data (depending on your distribution). I think you know your username :)

1
  • I changed the owner to www-data:www-data again and viola. Perhaps I'll add them to my users group.
    – Jacksonkr
    May 10, 2012 at 19:09
0

If the problem still persists and you're using linux (pobably a fresh install) check if SELinux is active.

1
  • ... By running "getenforce". If it's either permissive or disabled, SeLinux is not the problem.
    – weeheavy
    Apr 15, 2013 at 9:31
0

In my case I had no more free space on the server with svn. Check whether you have free space in temp partition and in partition where you have svn on the server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .