6
 ./configure
Configuring extundelete 0.2.0
configure: error: Can't find ext2fs library

It looks to me it's something related to e2fsprogs, however my OS has below software installed,

yum list |grep e2fs
e2fsprogs.i386                           1.39-33.el5                   installed
e2fsprogs-libs.i386                      1.39-33.el5                   installed
e2fsprogs-devel.i386                     1.39-33.el5                   base
  • I'm more interested in what you're undeleting :) – ewwhite May 11 '12 at 15:09
  • some log files are rolled over-_- – hetaoblog May 15 '12 at 8:18
14

The package you need is not actually installed. Please run yum install e2fsprogs-devel.i386 and try again.

Note that the last column in your yum listing shows "installed" for the first two packages, but shows "base" for the last. That indicates that the package is part of the base group but is not installed.

You may also need to remove the config.cache file in your extundelete source directory before running ./configure again.

4

On Ubuntu I had to install the e2fslibs-dev package

2

for someone looking for the same lib in the MacOSX: ext2fs_open is inside e2fsprogs package which is available to install from homebrew with the following command:

brew install e2fsprogs

but the configure will fail to find the libext2fs.a in the default path, so use following escape command to be able to extract correct path:

LDFLAGS="-L$(brew --prefix e2fsprogs)/lib"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.