0

i'm on a ubuntu machine when i fail to install jenkins with puppet with the following error:

/etc/puppet/modules/jenkins/manifests# puppet agent --no-daemonize --verbose
notice: Starting Puppet client version 2.7.1
info: Caching catalog for fqdn.myhost.com
err: Could not run Puppet configuration client: Parameter unless failed: 'apt-key list | grep -Fqe 'D50582E6'' is not qualified and no path was specified. Please qualify the command or specify a path.

and indeed i don't have this:

/etc/puppet/modules/jenkins/manifests# apt-key list | grep -Fqe 'D50582E6'
/etc/puppet/modules/jenkins/manifests#

i have followed explanation in this page and use first module specified there:

https://wiki.jenkins-ci.org/display/JENKINS/Puppet

i have downloaded the apt module from: https://github.com/camptocamp/puppet-apt/downloads

and placed it in puppet under modules.

anyone can help how can i overcome this? thanks

3

Doesn't it tell you where this error occurs? I.e. which line of your Puppet manifests? Do you have an exec somewhere, that has "unless"? The error message you get seems to be clear. Either you should fully qualify the executables, i.e.

unless => '/usr/bin/apt-key list | /bin/grep -Fqe D50582E6',

or you should add a path, i.e.

path => ['/bin', '/usr/bin'],
unless => 'apt-key list | grep -Fqe D50582E6',    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.