One of my scripts ends with the following error:

Can't locate SOAP/Lite.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at ./some_my_script.pl line 3.
BEGIN failed--compilation aborted at ./some_my_script.pl line 3.

So that, I've tried the following:

$ cpan -i SOAP::Lite

That brought me into the kinda infinite execution of endless downloads, testings all and over again. After more then 5 minutes on a decent CentOS server, I've pressed Ctlr-C and re-runned the script above, getting the same error message.

Hence, the questions (hopefully I am in the right forum to ask for help):

  1. What am I doing wrong, installing CPAN's modules? Why it is kinda in an infinite installation loop?

  2. Can you see the direct connection between the script error and the installation I've tried? Is it the right way to attack the problem?

If any data is missing - please just ask.

  • Can you paste at least some output to indicate what CPAN is doing? – EightBitTony May 14 '12 at 13:41
  • 1
    CPAN always turns into a game for me -- how long before CPAN decides that it has to rebuild Perl from source. If I get my thing installed before CPAN decides to rebuild everything, I win. I only win about 30% of the time. :) – David Mackintosh May 14 '12 at 19:10
  • 1
    "After more then 5 minutes" -- CPAN can easily take an hour on a speedy CentOS server. It may not actually be stuck in an infinite loop, but is actually iterating through the list of dependencies over and over but is actually knocking off one dependency at a time. It only looks like it's looping. Come back tomorrow and it might be done. Or it might fail and you'll have to start over from where it stopped. CPAN is a sysadmin torture device. Avoid it if you can. – Stefan Lasiewski May 14 '12 at 19:22

If you don't have things which otherwise conflict, there is a RPM in the EPEL called perl-SOAP-Lite that might fit your bill. EPEL has version 0.712-5.el5 today.

If you are running RPMForge instead, that repo has perl-SOAP-Lite version 0.712-3.el5.rf today.

If you don't have either, I personally recommend RPMforge.

  • assumed you meant this: sudo yum install perl-SOAP-Lite.noarch – BreakPhreak May 15 '12 at 9:10

Is there a CentOS package for SOAP::Lite? Called perl-SOAP-Lite or something like that maybe? You could try installing that with yum instead of using CPAN.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.