6

Have you used Cluster-SSH? It's a GUI (frontend) to secure shell (ssh) which function it's to let you write the very same commands to a lot of hosts. If you open a lot of hosts at the same time, cluster-ssh opens a window for each one of them. But these windows don't actually are perfectly ordered in the screen, I mean the same size and not overlapping. I always have to resize and move manually every windows to some kind of grid so I can see every terminal output at the same time.

Is there a way to tell cluster-ssh to order the generated windows in the size/position needed in some kind of configuration file??? If so, HOW?

I do this often with a lot of hosts, so I don't want to lose time arranging the windows as I need, I use Linux =) Thanks a lot =)

EDIT: This is a complement of the answer with a helpful tip. Even with the correct answer, it wasn't so easy for me to align the windows just as I wanted =/ If you get an error as this one:

$ cssh host1 host2
Illegal division by zero at /usr/share/perl5/App/ClusterSSH.pm line 1258, <CLUSTERS> line 3.

Just change the value of terminal_size to something lower.

Also at first I didn't notice any change at all in the size of the windows. I noticed that (al least in Ubuntu 11.04 + KDE environment) retiling the windows it's useless. In order to apply the resize, you must minimize all terminals and ten retile. That way the real size it's applied. I don't know why this behavior. A bug maybe?

Greetings.

5

cssh is supposed to tile the windows automatically. Try adding the following to ~/.csshrc (the manpage contains all the options):

terminal_size = 80x24
console_position = +0+0
window_tiling = yes
always_tile = yes
4
  • UPS! I did open the man but I didn't read that section THANKS =)
    – Metafaniel
    May 16 '12 at 18:04
  • 2
    I use XFCE4 with a panel at the top of the screen. To account for this, I needed the screen_reserve_top= option, otherwise the first row of terminals overlaps the 2nd row of terminals.
    – bobpaul
    Apr 24 '18 at 20:12
  • Note that the config is now located at ~/.clusterssh/config Aug 14 '18 at 20:23
  • Beware, console_position is only do move the position of the box where you type commands, not offsetting the terminals. (@bobpaul's suggestion helped me though)
    – mveroone
    Apr 9 '19 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.