We recently setup one of our users with a brand new Windows 7 computer, however she is unable to delete certain files. With some testing, I found I cannot move, rename, or view properties of these files either.

When trying to delete the file, it just sits at the "Preparing to recycle" popup, however the "from" section says "Discovering items..."

Preparing to recycle from discovering items

Clicking "More Details" on the popup shows me that it can't find the file name or where it's recycling from:

Preparing to recycle - more details

Other notes...

  • All the affected files are .pdf files that get created via a scanner. Other pdf files are fine.

  • Opening the files works fine. I can open the file, Save As a new file, and delete the new one just fine

  • Trying to delete the file via command prompt just sits there

  • Rebooting the computer will let me manipulate the files like normal, however this user is responsible for scanning hundreds of documents a day and I'd rather not have to tell her to reboot her computer to delete files.

  • The user is part of the administrator group on the computer

  • The Owner of the affected files is the user

  • attrib of files is just A

  • 1
    Have you tried disabling the virus scanner? – Dan May 16 '12 at 14:59
  • @Dan There currently is no anti-virus software installed (that's on my TODO list later today). Why do you think the scanner could be causing the problem? – Rachel May 16 '12 at 15:02
  • 1
    Because virus scanners can (sometimes mistakenly) "detect" a virus or malware and prevent access to the file causing all sorts of fun errors from applications and operating systems. – Bart Silverstrim May 16 '12 at 15:05
  • run chkdsk /x C: and reboot the computer. See if it finds any problems. – Chris S May 16 '12 at 16:32
  • @ChrisS I will try and get that done later on, however the entire machine is new, HDD included, so I would be surprised if that was the cause of the problem – Rachel May 16 '12 at 16:43

It's quite likely that the application doing the scanning to PDF hasn't quite let go of the file handles for these PDFs yet. Hence why a reboot fixes things, as the application is unloaded from memory and all file handles are lost.

Therefore it could be required to force kill the scanning application's process from Task Manager or use something like LockHunter to unlock the file manually.

If these aren't workable solutions, I'd check to make sure the PDF scanning software doesn't have an update available from the manufacturer, or that you can't use the built-in Windows scanning functionality that might be a bit more robust (but only available to JPG, I think).

  • Thanks for the LockHunter link, that helped us identify that it wasn't the scanning software causing the problem, but rather another software that we were uploading the scanned files to. – Rachel Jul 2 '12 at 13:07
  • So the end result was that you fixed your issue? Or still some work to go? @Rachel – Ashley Aug 21 '12 at 18:04
  • It didn't fix the issue, but you helped us identify the cause of the problem and provided a workaround to unlocking the files when needed. We submitted a support ticket a few months back to the company that owns the software locking the file, but are unable to reproduce the issue on any other machine so I'm assuming the ticket is lost in some dusty pile that some poor intern will have to go through one day. Thank you :) – Rachel Aug 21 '12 at 18:19
  • Good to hear you've had some resolve, however :) – Ashley Aug 23 '12 at 13:51

Well, for a workaround while you're waiting for a resolution from the software manufacturers, you could try deleting them in safe mode, or from a PE... or just kill that software's process in Task Manager so the files are no longer locked.


I just had the same issue today. Updating acrobat reader fixed the problem. (on one pc from 8 to 9, on another just updated 9 to the current version) I still don't understand why does acrobat had anything to do with file deletion but it was working fine after update/restart the pc. No, before that a simple restart did not fixed the issue. Maybe it has something to do with the pdf preview or something like that.


I had this issue today, the PC is running Windows 7 32-bit, and Adobe 8.3.1 Acrobat Professional is installed. No version of Adobe Reader was installed when this issue occurred.

I was able to fix it by installing the latest version of Adobe Reader. Initially made the reader the default PDF viewer. Restarted the computer and the issue is gone. I've uninstalled the Adobe Reader, rebooted the PC, and tried to recreate the problem and it did not happen again! Not sure what installing and uninstalling Adobe Reader did, but it fixed it for me, so yay!

hope this helps.


My solution was to run the FileAssassin from malwarebytes. Just make sure you end explorer through task manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.