0

My Drupal installation is having all links to nodes show up with a File Not Found error. Admin pages and such are ok, it's just pages with ?q=node/#

I tried using Update.php to fix anything, but that didn't do it.

Any other ideas?

  • Was it working before or is this a new install? did you change anything in your apache config lately? is drupal's .htaccess file still in its directory? – brad.lane Jul 10 '09 at 16:05
3

Make sure your drupal directory has its .htaccess file. If this is missing, it can cause nodes to not be displayed.

Make sure your drupal directories have all the correct permissions.

Make sure you have mod_rewrite enabled in your apache config if you have the clean urls setting enabled in drupal. If it's enabled, try disabling it to see if that makes a difference.

1

The node content was missing from that table and so they weren't working. Once the content was restored, everything worked like a charm.

  • haha...that would be a problem! – Sam Nov 2 '09 at 15:57
0

I was having this problem and ran update.php. Even though it didn't detect a need for updates, this still worked for me. Promptly backed up database and directory in case problem arose again. I had taken a look at the database tables but didn't find anything obviously wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.