0

I am getting the error "The Name cannot be resolved. The operation failed." for users of a certain database on our Exchange cluster for our tests to a new server migration with a Client Access Server.

The email actually worked after it was moved to a new server until we deleted the address and attempted to again resolve the user account and server. We can't get it to work at at all now.

The users cannot resolve the Microsoft Exchange Server or Mailbox when entering the info into a new account and I ran a test with the account at testexchangeconnectivity.com and the error below came up:

Testing the Name Service Provider Interface (NSPI) on the Exchange Mailbox server.
An error occurred while testing the NSPI RPC endpoint.

Test Steps

Attempting to ping RPC endpoint 6004 (NSPI Proxy Interface) on server (MailServer the account was migrated from).
The endpoint was pinged successfully.

Additional Details
RPC Status Ok (0) returned in 953 ms.
Testing NSPI "Check Name" for user user@domain.com against server (MailServer the account was migrated from).
An error occurred while attempting to resolve the name.

Additional Details
An unexpected error was returned from NspiResolveNames. Code: 2147500037

Auto discover is set up as well and points to the proper server to connect to but the internal server name(where you enter the account as well) shows the old server.

Any ideas would be appricated! Thanks

0

Figured it out. We updated the old and new server to the latest version and the problem went away. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.