4

So, we bought some hardware for one of our aging servers.

And, for whatever reason that utterly baffles me, the driver files do not exist on the included CD. Instead, they exist in floppy disk image files on the CD, which first must be written to a floppy disk, from which you then copy the files. Unfortunately, every floppy disk we have is corrupt due to age. So I need a way to extract the files from that image.

Please note that the reason we don't just replace the server entirely (which is definitely due) is because that is not in the budget right now.

EDIT: the disk image is in UFS format apparently. Windows programs will not work!

5
  • What is the file extension on the floppy disk images?
    – Adam Brand
    Jul 10, 2009 at 17:39
  • What's with the "wtf" tag? lol
    – l0c0b0x
    Jul 10, 2009 at 17:50
  • What OSes are you using? I assume Windows.
    – J. Polfer
    Jul 10, 2009 at 17:59
  • 3
    l0c0b0x: As in WTF would anyone do such a painfully boneheaded thing as force sysadmins to create floppies from an image when you can just... ah, put the files on the CDROM? Even if I had floppies that worked, it would still be painfully boneheaded. Sheepsimulator: The server is FreeBSD 4.9, I have a Ubuntu workstation, and access to windows workstations in the office.
    – Ernie
    Jul 10, 2009 at 18:29
  • @Ernie - because maybe images come from a time when they didn't have cdrom's ? Images of some installation discs which required for everything to be just like on the discs, including disc name and so on.
    – Rook
    Jul 10, 2009 at 22:36

7 Answers 7

2

Try loop mounting the image. Since floppy images don't have partitions this can be done easily:

sudo mount -o loop floppy.img /mnt/tmp
# or
sudo mount -o loop,ro -t udf floppy.img /mnt/tmp
2
  • That almost works. I can mount the image, but then when I try to read from it I get the error "Input/output error"
    – Ernie
    Jul 10, 2009 at 18:25
  • Technically speaking, this appears to be the right solution. But the disk image is unreadable due to an input/output error. This may also be the reason why none of our floppies worked as well. I think the driver developer is simply out to lunch, not only for the requirement that the floppy be imaged, but because the floppy image on their website is also not working. FYI: Avoid Highpoint 1640 RAID controllers.
    – Ernie
    Jul 10, 2009 at 20:32
6

Try using Virtual Floppy Drive to virtually mount the floppy image. Then you should be able to access it.

EDIT: Considering the UFS file, you have the capabilities to do this in a linux/unix environment using loop devices. I found some instructions on this in the BOCHS user manual and here is the losetup man page for Unix. Good luck, and I hope that helps.

7
  • 1
    Hah! I beat Evan to a response! :-p
    – RascalKing
    Jul 10, 2009 at 17:41
  • +1 - I use this to get files out of disk images, or with obstinate installers that demand to write BIOS updates, etc, to a floppy disk. This ought to let you get those files out. You beat me... I posted that about 30 seconds after you... >smile< Jul 10, 2009 at 17:41
  • Heh heh... you got lucky. I'm making lunch. Jul 10, 2009 at 17:41
  • I was going to ask if you were in the bathroom :-p
    – RascalKing
    Jul 10, 2009 at 17:47
  • Yeah, that worked well enough, but the floppy image is in UFS format. :(
    – Ernie
    Jul 10, 2009 at 17:56
1

WinImage can extract/insert files into images. It's not free, but there's a 30 day trial that'll be enough for one off usage.

1

Have you looked at WinImage

Reasons:

  • Free
  • 64 bit support
  • Does not install a service
  • Can make bootable drives from other drives
  • Make physical drives into virtual and vice versa
0

I would try UFS Explorer in Windows, especially if it is a UFS image. Even if it isn't free to do what you need, I would think that for the meager payment to the developers your work will be much faster.

1
  • I'm not sure what you mean by the latter. This certainly doesn't work: $ mount freebsd4x.img /mnt/floppy mount: freebsd4x.img: Operation not permitted
    – Ernie
    Jul 10, 2009 at 18:09
0

I've seen these utilities suggested on other sites as possible solutions:

0

Sounds like OS/2 Warp 4. So I would google there first and see how they do it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .