I need to use RabbitMQ on Ubuntu 10.04. I have installed it before, but it was for code testing/learning purposes. I want to use newer versions of Erlang and RabbitMQ than the ones provided in the Lucid Lynx repositories for actual use, because many things have changed in the latest versions. The two major points concluded from the software changes are:

  1. In RabbitMQ, some client libraries no longer work with the ancient repository version, which is pre-2.0.
  2. The apt package erlang-nox is Erlang version R13B, which is the minimum version required for RabbitMQ. However, since SSL is a strict requirement of our architecture, we need at least R14 according to this page.

RabbitMQ offers a .deb package, but it explicitly requires a package be installed via the package manager called erlang-nox. Instead, I tried compiling both Erlang and RabbitMQ from sources, but RabbitMQ has been an endless rabbit hole of dependencies; even the Makefile has dependencies, as it is trying to use programs that aren't installed in Ubuntu Server by default. Of course, the programs that it tries to use also have many dependencies in apt. I'm not afraid of resolving a few dependencies normally, but I don't really want to seek out and install 500-1000 MB of dependencies to install RabbitMQ, no matter how important it is.

I thought Ubuntu Backports might be an option, but I learned that not every package has a backport.

We do plan on moving to Ubuntu 12.04 this year, but it's not a priority right now... deploying RabbitMQ to production is.


I usually over right the default install of ubuntu with a newer version compiled from source and it should work just fine

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.