I'm trying to setup a slave DNS server but the reverse mapping doesn't seem to resolve.

When I try 'nslookup nslookup' it returns


** server can't find NXDOMAIN

I've tried setting up a reverse zone, but it still doesn't work.

$ttl 38400    IN  SOA ns2.madtek.co.za. xxx.xxx.xxx. (





            38400 )    IN  NS  ns2.madtek.co.za.    IN  PTR ns2.madtek.co.za.

Can anyone help please?


The nameserver which resolves the PTR records for that subnet is ns1.ghostdns.de which, I'm guessing, you do not operate. It looks like it is operated by hostmaster@ghostnet.de.

You need to contact whoever does operate that nameserver and ask them to add a PTR entry for

$ dig -x -t SOA
; <<>> DiG 9.7.0-P1 <<>> -x -t SOA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 35612
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;   IN  SOA

214.249.94.in-addr.arpa. 0  IN  SOA ns1.ghostdns.de. hostmaster.ghostnet.de. 2012032301 10800 1800 604800 10800

;; Query time: 32 msec
;; WHEN: Sat May 26 15:16:41 2012
;; MSG SIZE  rcvd: 116

As James has noted you unlikely to be the administrator for the reverse zone (PTR records). Contact whoever provides your IP address and ask them to make the change. This usually takes a few days. You There will be a further day after they implement until cached values expire on other DNS servers.

You could ask them if they support delegating reverse lookups. This is defined in RFC 2317. You will need to make slight modification to the above zone file for it to work.

For IPv6, it should be easier to get the reverse zone delegated to you. In IPv4, you usually don't get the reverse zone delegated unless you have at least a /24 block allocated to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.