8

I have a dump.rdb file, which is in the same directory as redis.config.

When I start my sever:

redis-server ./redis.config

It does not load the data in that 1 GB file.

How do I load that data?

9

Edit your config file to set the dir option to the current working directory:

# The filename where to dump the DB
dbfilename dump.rdb

# The working directory.
#
# The DB will be written inside this directory, with the filename specified
# above using the 'dbfilename' configuration directive.
# 
# Also the Append Only File will be created inside this directory.
# 
# Note that you must specify a directory here, not a file name.
dir /current/working/directory
2
2

Do as follow:

  1. modify the redis.conf, disable the appendonly.aof
    appendonly no
  1. Restart the redis-server

  2. Run redis-cli BGREWRITEAOF, to create a new appendonly file.

  3. Modify redis config appendonly to yes and restart your redis-server

Please see this

1

We found we had to switch aof off beforehand otherwise redis creates a blank aof at boot and uses that instead of the rdb file. Once redis creates a populated aof then you can switch aof back on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.