I have a particular network share that's giving me grief. Basically, we had two NAS devices which had to be moved to another building. I updated /etc/fstab to the new IP addresses and tried to remount them. One of the NAS devices went through the process just fine. The other one, however, is being rude.

I tried the suggestions in this thread, but they didn't work:

When I type umount -f /mnt/gsrnas2, it says Device is busy

If I try to cd /mnt/gsrnas2 and then ls, the terminal locks up and I can't break out with Ctrl+C

When I try fuser -mk /mnt/gsrnas2 or lsof | grep /mnt/gsrnas2, the terminal freezes with those commands as well.

All of the other NFS mounts on the server are behaving just fine, and I can umount and mount them without any problems.

I'm sure that no one is actively using this mount point, because it points to an unoccupied IP address.


First use the lsof -P | grep filename command to see which processes have a file handle for files on your device. You can use kill or something similar to try and terminate them gracefully.

If nothing respond to the polite requests, then its not going to clean up gracefully, so you can make some progress with the lazy and force option like so;

umount -l -f /mnt/gsrnas2
  • 1
    That got it. AND I was able to immediately remount. Bonus! Thanks for your help! – DeeDee May 30 '12 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.