I have a problematic SBS 2003 installed on a Dell PowerEdge SC430 server. The server has two SATA drives originally configured as a RAID-1 mirror using software RAID (i.e. no RAID controller). After a problem with disks, the server was rendered non-bootable. So the disks have been replaced and the plan was to restore from backup.

A basic OS installation was done and interrupted before the main SBS install, rebooted into Directory Services Restore Mode then NTBACKUP used to restore a recent backup image. The restore succeeds but when the server is rebooted, it gets as far as the graphical boot loader screen (the graphical Windows logo with the animated white progress bar) and after a few seconds, the server just reboots. This happens even when booting into safe mode.

I can't understand why this won't boot correctly. Any ideas?

  • Seeing as you all thought my question was worth answering, how about voting me up? – Tim Long Jul 12 '09 at 11:26

if you have a full backup from sbs 2003 using the sbs wizard, it will be in bkf format. then you need to install a vanilla flavour of sbs 2003 with the exact service pack as when you took the backup. once you do the initial install you then need to go into dir services restore mode and choose to install or restore the c drive and the system state. If you have more than one partition i would probably suggest, or i normally do this when trying to test recovery processes, holding off on the other data restore, you can do that later.

please reply to whether you did the above? thanks.gd

| improve this answer | |
  • another thing you might have issues with the raid drivers so the more info you cna give as to how you restored it would really help.gd – user8256 Jul 12 '09 at 3:37
  • This sounds a lot like what the poster said he did already. Further, he states that he's not using hardware RAID, so there aren't any RAID drivers to worry about. (This particular box doesn't even need an "F6 floppy" driver for the SATA controller, if I recall properly. – Evan Anderson Jul 12 '09 at 4:17
  • i assumed software raid like an ich chipset that would require you to maybe build a slip streamed raid driver included to sbs 2003 disc 1 using somthing like nlite.gd – user8256 Jul 12 '09 at 4:30
  • No RAID drivers are needed, it's using the RAID that's built into Windows. – Tim Long Jul 12 '09 at 4:47
  • Question: I don;t have install media that is at the same service pack level that the backup was taken at. Install media is RTM and the system was backed up at SP2, IIRC. Does this really matter, considering that the system partition is being overwritten by the restore? – Tim Long Jul 12 '09 at 4:48

Quick aside, the Directory Services Restore password is just the local administrator password just as on a non-DC. You can use http://home.eunet.no/pnordahl/ntpasswd/ to reset it (IME blanking the password works best), then boot into DSR mode if you need to.

When the server appears to be starting then reboots it's usually because it's getting confused about which is the boot partition (or disk controller, though probably not in this case). This can be a bugger to fix. It happened to a colleague of mine recently, but he got it going by booting a recovery console and running the MBR fix.

Did the server originally have a Dell system partition? If so you need to recreate this by using the Dell pre-installation CDs before you do the Windws install. The CDs are downloadable from the Dell web site.


| improve this answer | |
  • +1 about the Dell partition. The partition numbers need to match. – JS. Jul 12 '09 at 9:54

Solved [phew]! Here were the steps that got me back online:

  1. Clean all disks using Diskpart
  2. use Dell Server Assistant to install SBS 2003 RTM.
  3. Install Windows Server 2003 SP2
  4. Restore backup image, including System State, but excluding Boot.ini. In backup options, set "Overwrite files only if existing file is older" (this is contrary to Microsoft's instrictions, which specify the 'always overwrite' option).
  5. Reboot and complete cleanup steps from step 20 of Microsoft's instructions.
  6. Rebuild the RAID-1 mirror(s).

Lesson learned: software raid is more of a marketing pitch than of any real value.

| improve this answer | |
  • Special mention for Evan Anderson who spent some of his precious sleep time giving me moral support on Live Messenger. – Tim Long Jul 12 '09 at 11:19
  • Glad to hear you got it running. re: software RAID - I don't think I'd say that it's a "marketing pitch" at all. I don't know what rendered your machine unbootable to begin with, but software RAID does a great job of protecting against single-disk failures in Windows. – Evan Anderson Jul 13 '09 at 17:21
  • I think what got you was the version of Windows you installed with before you restored. The Windows you installed must be the same service pack level as the backup being restored. The overwrite files option is a ...has bitten me more than once, too. I had a Dell PERC RAID blow up my SBS box once too, so don't obsess too much about hardware vs. software RAID. – dmoisan Aug 26 '09 at 23:41

Hmm... I have a couple of that server out there in the world running W2K3, but I can't say that I've had to DR one back from bare metal.

For starters, I'd consider booting once with boot logging enabled (it's a choice in the same pre-boot menu where you'd choose "Safe Mode"), then boot to the recovery console (or better, a W2K8 / Vista / Windows 7 setup CD so that you get a "real" command prompt) and have a look at the "%SystemRoot%\NTBTLOG.TXT" file. There's a chance that seeing the last few driver loads might give you somewhere to go.

I'd consider doing a "Repair" install of Windows on top of the restored installation, but that's ugly and messy and only something I'd do as a last resort.

Keep us updated re: your findings. If you get more information, drop it in here and I'm sure "the community" will share its thoughts. I know I will.


If your temporary operating system reinstallation was into the same directory as the original install (i.e. both in "C:\WINDOWS", etc), then the registry containing your temporary installation has already been overwritten by the restored registry, and as such, the directory services restore mode password you set during your temporary install is gone and should not be a factor.

If you did a "Repair" with an RTM CD and the box was SP2 at the time of backup that may account for the STOP 0xC0000021A that you're seeing right now, but I'm not sure. It might be worth it to get a slipstreamed SP2 media and try a repair from that. (If you don't have one you could use a tool like nLite to build one. Hopefully you've got a CD burner and some blanks handy...)

You've got me interested to the point that I may try and take down one of my Customers' PE430SC's, throw a scratch drive in it, and try a bare metal restore. Of course, that doesn't help you tonight (and I'm guessing you're trying to get this going for Monday morning).

Since you haven't RAID'ed the disks yet you might try setting the current disk you're playing with aside, throwing in the second disk, reinstalling Windows one more time, and doing a restore of just the %SystemRoot% and "Program Files" directories again, just to see what happens. Before you restore the box you could apply SP2 just to see what happens. (You might take an image of the box in that state, too, assuming you have some software with you to do that, just so you won't have to reload Windows AGAIN during this whole fiasco.)

You've got me a little bit stumped. I've done a goodly number of bare-metal Windows NT / 2000 / 2003 recoveries and I can't say that I've seen what you're seeing.

| improve this answer | |
  • Tried an in-place repair, that allowed teh system to boot a little further but eventually blue-screened with a STOP C000021a "Session manager failed to initialize". Indications are that this is related to Winlogon or CSRSS failing to start correctly. One thing that's bothering me. I don;t know the DSR mode password, so I can't start a recovery console. I wonder if this is what's causing the backup to not restore correctly? i.e. the password I set on the base install not matching the one on the backup set. Comments? – Tim Long Jul 12 '09 at 4:45
  • I'm dropping an edit on now. – Evan Anderson Jul 12 '09 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.