I have a strange problem. Iam trying to create a shared folder via the add-hardware->filesystem option. For Type and Modus i choose Passtrought and for Driver Path. The Source Path is /free and target is mytag. I mount it with: mount -t 9p -o trans=virtio mytag /mnt/test -oversion=9p2000.L Everything worked without problems. But when i enter /mnt/test and do a ls, i get "ls: Öffnen von Verzeichnis . nicht möglich: Keine Berechtigung" in english something like "ls: cant open folder . no permission"

I set permissions of /free to 777 recursivly but nothing changed. Also tried some other modes in virt-manager but nothing changes. Do you have any clues, what i am doing wrong?

The guest-os ist Ubuntu 12.04 and the host-os is Ubuntu 11.10

Thank you for your help.


1 Answer 1


You asked for any hints, so here we go.

  1. First, -orw in the mount options can help,
  2. furthermore the user and group ids should match on both systems (they likely do if you use general users like ftp, www-data etc.)
  3. check under which user the vm is started (e.g. kvm or libvirt-qemu - see /etc/libvirt/qemu.conf).
  4. apparmor can create closed doors, too, there is various stackoverflow questions and posts on this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .