1

I am using following directions in an attempt to install gitlab on Debian 6.0.5 https://github.com/gitlabhq/gitlabhq/blob/stable/doc/installation.md

I am getting an error when i'm running following command

sudo -u gitlab bundle exec rake gitlab:app:setup RAILS_ENV=production

WARNING:  #<ArgumentError: Illformed requirement ["#<Syck::DefaultKey:0x00000004b52198> 1.1.4"]>
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = %q{carrierwave}
  s.version = "0.6.2"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["Jonas Nicklas"]

....more error....

    s.add_dependency(%q<mini_magick>, [">= 0"])
    s.add_dependency(%q<rmagick>, [">= 0"])
  end
end
WARNING:  Invalid .gemspec format in '/usr/local/lib/ruby/gems/1.9.1/specifications/carrierwave-0.6.2.gemspec'
Could not locate Gemfile

Some pointers to what could cause this would be much appreciated, i have only little experience with RoR and it seems to be related to that.

1 Answer 1

0

i found out what went wrong, the package libreadline-dev could not be found when installing packages at the beginning of the installation procedure, this caused the whole apt-get install command not to execute, which i overlooked. I removed the package from the install list and everything went smooth. ( Also the installation instructions assume that you have already installed ssh. )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .