After upgrading from Fedora 16 to Fedora 17, Traffic Control no longer seems to work.

Running # tc qdisc show will output:

qdisc pfifo_fast 0: dev eth0 root refcnt 2 bands 3 priopmap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1

However, if I run # tc qdisc add dev eth0 root netem delay 100ms or similar commands such as # tc ... loss 2% or # tc ... corrupt 3% I get the following:

RNETLINK answers: No such file or directory

Downgrading back to Fedora 16 allows me to use Traffic Control without this problem, so I'm convinced it's not a hardware issue.

This question is similar to tc netem possibly missing but I believe the right components were installed by checking # yum provides */tc and ascertaining that tc is from the package iproute, whose latest installation I have.

Is netem part of another package I must also install?


In Fedora 17 they moved a lot of unused (in common usage I guess) modules for the kernel into the package kernel-modules-extra.

Install that and your problem will go away.

  • 2
    This fix works, but I had to reboot to get the new kernel extras to be loaded.
    – ostler.c
    Sep 10 '12 at 17:17
  • 1
    I am using CentOS 5.8 and I am having this same problem, but I cannot find the package kernel-modules-extra (or any variation on that name).
    – smcg
    Nov 5 '12 at 16:21
  • yes, it worked for me too but do not forget to reboot
    – thomas
    Jun 21 '17 at 14:39

FWIW I am seeing the same issue after an upgrade from FC16. the tc command is in the 'iproute' package and I believe the netem qdisc is defined there.

I've verified that I get the same response to other tc commands (besides just trying to add a netem qdisc) with e.g.:

# tc qdisc add dev eth1 handle 1:0 root dsmark indices 1 default_index 0
RTNETLINK answers: No such file or directory

This seems to be documented at https://bugzilla.redhat.com/show_bug.cgi?id=823316

  • Thanks for the info, I didn't consider the possibility of it being a bug.
    – Daniel
    Jun 6 '12 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.