I have been struggling with a problem on my Windows Server 2008 for the past 4 - 5 hours and cannot figure out whats wrong. I have tried pretty much everything that I found on google and all the links are purple. Hopefully you guys can help me.

I am running a Windows Server 2008 Standard edition with the latest updates as of today. Furthermore I am running a Windows Server 2003. Both are virtual machines on my ESXi 5 server.

My network is:

W2k8: is the PDC running ADS, DHCP and WDS

W2k3: AND running Routing and Remote Access and ISA 2006 Enterprise

In my internal network ( I have my client machine ( that runs a VMWare Workstation.

I am trying to deploy Windows 7 Home Premium to a virtual machine on my VMWorkstation via PXE.

I have set the Workstation's VM network adapter to "bridged" so that it uses the physical network adapter and is connected to my internal network.

The DHCP pool is configured to give IP addresses from (works for normal clients and is not used up)

When I start my VM with the PXE I get the error: PXE-E52:proxyDHCP offers were received. No DHCP offers were received

Apperently this means "that means that WDS responded but the DHCP server did not."

People suggested to direct the traffic to both WDS and DHCP on the router, since everything is on the same subnet there is no need for that as the broadcast is seen by everyone (WDS and DHCP)

No reservation for the virtual mac addrs is made on the DHCP.

Furthermore it was suggested to configure the DHCP options:

  • Option 60= PXEClient
  • Option 66= WDS server name or IP address Option
  • 67= Boot file name

However, this is not recommended by Microsoft, I tried it and it did not solve my problem.

The configuration on the WDS (My System is German therefore the actual naming might be different):

PXE response tab:

  • PXE responses is set to "ALL (known and unknown)"


  • Do not listen to port 67 is NOT ticked - if I tick this I do not get any responses and the PXE errors gets PXE-E51 that neither DHCP or proxyDHCP were received
  • DHCP-Option 60 for "PXEClient" is ticked

The confusing part here is that it is advised in the tab to tick the first option since it is on the same server.

Network Configuration Tab:

  • Use the following IP-Address range for Multicast-IP-Address: -

Thats not the default one, however it is in the allowed range.

The UDP port range is the default since it is not advised to change them.

I tried to change the "networkprofile" from 100mbits/1gbits and custom. I am running a 1gbit network with CAT6 cables and 1gbit netgear switch 5 ports. Everything is configured to use 1gbit.

The WDS is authorised for the DHCP server.

My ISA 2006 configuration:

For the internal networking i have configured the following policy array: Allow protocols on internal network including the w2k3 host:

  • 67,68,53,ICMP,
  • 4011 UDP receive,
  • 64001-6500 UDP send receive,
  • 69 UDP send

Routing and Remote Access I tried the DHCP relay agent configuration that was suggested as well, but that did not work

I would highly appreciate anykind of help because I am pretty much done here with my nerves.

Thank you very much in advance.

  • Option 60 is needed, but since DHCP is on the same server as WDS, you do not need 66 and 67 to be configured. Can you remove those options and let us know? – dwolters Jun 6 '12 at 16:02
  • @WinOutreach4 it is configured that way. I ticked the box in the DHCP tab, it puts the option to the DHCP server. The others are not configured. – Richard Jun 6 '12 at 17:18
  • The error message "PXE-E52:proxyDHCP offers were received. No DHCP offers were received" means that the PXE responded, but DHCP did not assign an IP address. Can you check the logs on the DHCP server to see if there is anything that tells us what the problem is? – dwolters Jun 6 '12 at 21:21

Alright. The problem is solved.

Here is what I did: I switched off my ESX.

I started it again: DHCP started I tried the PXE install, got the 4011 error. Double-checked if my WDS is running:

WDS failed to start. Why? Because port 67 wass already used.

I opened WDS and then set the "Do not use port 67" option and thats it. Everything worked.

So at the end it was just a simple restart to recognise, that I need to start the DHCP first so it gets assigned the port 67 for sure and that WDS does not care about that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.