4

If I run postfix check on my debian squeeze server, I get this:

postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_nisplus-2.11.3.so and /lib/libnss_nisplus-2.11.3.so differ
postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_files-2.11.3.so and /lib/libnss_files-2.11.3.so differ
postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_compat-2.11.3.so and /lib/libnss_compat-2.11.3.so differ
postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_hesiod-2.11.3.so and /lib/libnss_hesiod-2.11.3.so differ
postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_nis-2.11.3.so and /lib/libnss_nis-2.11.3.so differ
postfix/postfix-script: warning: /var/spool/postfix/lib/libnss_dns-2.11.3.so and /lib/libnss_dns-2.11.3.so differ

Somebody know a solution to fix this ?

4

/var/spool/postfix is a chroot where postfix can optionally run, The idea is that if postfix is somehow compromised, the only thing the attacker would have access to is this small subset of your system instead of your whole system. The warning here is that the files in /var/spool/postfix no longer match the files in your regular system that they were copied from. You might verify that the files in /lib were expected to change (like, was libnss recently upgraded?), then consider copying these versions into the /var/spool/postfix/ chroot, so that the chroot also gets this upgrade.

2

As per stew's answer, to kindly save people typing. As root:

cd /lib; cp libnss_files-2.11.3.so libnss_nis-2.11.3.so libnss_dns-2.11.3.so libnss_compat-2.11.3.so libnss_nisplus-2.11.3.so libnss_hesiod-2.11.3.so /var/spool/postfix/lib/

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.