... this isn't as bad as it sounds since it's just a test domain.

I created a small test domain on my vmware server to play around with active directory settings. I had two DCs and a Win7 & winXP client. At some point I needed the space so I backed up all of the VMs to tape and forgot about it for six months. I recently decided I wanted to play around with some more AD settings in the test domain, so I restored the domain controllers from the backup and tried to log in.

I got the ominous sounding "There are no logon servers available to service the login request" message when I tried to log into the test DC. Apparently active directory gave up the ghost and I can't even log into the domain controller.

So, is there a way to fix this - some kind of defibrilator for active directory to shock it back to life? If not it's not such a loss since it is fairly easy to whip up a few more VMs and make a new test domain.

The Domain Controllers are both Server 2008R2 core.

  • Did you restore the DC's from a true backup or from just a VM snapshot? – SturdyErde Jun 7 '12 at 16:50

90% of all AD problems are DNS issues. Make sure the DNS server that these AD servers point to is running and that the entries for the domain controllers are correct.

  • 1
    More like 99% of all AD problems are DNS issues. – Chris S Jun 7 '12 at 1:09

Try powering down the VM's restarting them, one at a time, starting with the FSMO role holder (although that shouldn't really matter), then the second DC, then all the rest. Make sure each computer is at the "Press CTL + ALT + DELETE to log on" screen before starting the next one.

There's no technical reason the AD domain should be borked just by being turned off. I regularly shut down my lab VM's and lab AD for months at a time and restart them with no issues when I need to use them.

  • Maybe yours didn't pass the tombstone lifetime? – Bigbio2002 Jun 6 '12 at 19:49
  • I'm not sure that it would have much bearing if both DC's were turned off for the same length of time and both restarted at the same time. If there were lingering object problems due to the DC's not having replicated for longer than the tombstone lifetime I don't think it would manifest itself with the error the OP is getting. – joeqwerty Jun 6 '12 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.