I have recently bought a Netgear WNDR3800 router to use it in my home network. But just the same day I installed it, I noticed a strange behaviour of Finder and iTunes. Let me explain it further. There is a Synology DS111 NAS attached to that router and two Macs with Mac OS X Lion. One of them is connected by a cable and the second one wirelessly.

Before I changed my router to the new one I mentioned above, Finder always used to display my NAS on its sidebar. So I could just click its network name to access shared folders existing on it. But after I installed WNDR3800, I can no longer access the NAS that way. It is no longer displayed. I always have to mount it manually by typing its IP address using the Finder's 'connect to server' option.

The same NAS supports TimeMachine backups and has an inbuilt DLNA server. And the same situation here. I can't perform a backup because my NAS is no longer accessible in TimeMachine preferences. iTunes does not display it as well (as a multimedia server) even though it used to before I installed that router.

What's important, everything works fine for a couple of minutes after I restart the router or the NAS. Or even when I change the NAS's IP address it becomes accessible again in Finder, TimeMachine and iTunes, but only for some time. Both the Mac computers I mentioned behave the same way.

And all those issues have been taking place sice I installed that new router. Before I did that, everything had worked fine. My old router was Netgear WGR614v10.

Would you be so kind to tell me what you think could possibly be the reason of that behaviour? What settings of the router should I look closer at? I'm not a network specialist, but is it possible that some network packets are blocked for some reason?

I will be grateful for any clues you give me. Thank you.

closed as off-topic by Falcon Momot, Michael Hampton Jun 29 '13 at 5:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about hardware or software used in a home setting are off-topic because they require answers that may not be practical for the business and support professionals here. You should try asking on Super User instead." – Falcon Momot, Michael Hampton
If this question can be reworded to fit the rules in the help center, please edit the question.


I think I managed to solve the problem. I installed an alternative firmware (DD-WRT) on my Netgear. Now everything works perfectly OK. Many thanks to the developers of that firmware! The router not only works properly now, but has much more features than it used to have in the original firmware from the manufacturer.

What's worth mentioning, I have recently bought another router - Belkin F7D4301. And same issues here: my NAS was not automatically detected (as well as other machines in my home network), TimeMachine did not work and the DLNA server running on the NAS was not accessible from iTunes. So guess what I did - DD-WRT solved these issues here as well!

Not the answer you're looking for? Browse other questions tagged or ask your own question.