0

Having troubles getting VSFTPD running on Fedora 14. Here is what I have done so far, please let me know if I am missing something. When I try to connect through FTP it says connection time out.

Installed VSFTP with yum

yum install vsftpd

Edited config file

vi /etc/vsftpd/vsftpd.conf

Started service and made sure it would always start up

service vsftpd start
chkconfig vsftpd on

Added and configured a new user

/usr/sbin/useradd upload
/usr/bin/passwd upload
usermod -c "This user cannot login to a shell" -s /sbin/nologin upload

Added firewall rules

iptables -A INPUT -p tcp --dport 21 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 20 -j ACCEPT
service iptables save
service iptables restart

Checked netstat (In reply to comment below)

tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      23752/vsftpd        
3
  • Anything in the logs? Anything related to vsftpd in netstat -anpt output?
    – cjc
    Jun 7, 2012 at 13:21
  • Is SELinux running in enforcing mode? Does temporarily disabling it solve the problem? Jun 7, 2012 at 13:32
  • CJC: Nothing shows up in tail -f error_log when I try to connect, and netstat is pasted above. KENNY: No idea what that is, I am somewhat novice.
    – Louis W
    Jun 7, 2012 at 13:35

1 Answer 1

0

Can you check the parameter listen_address in vsftpd.conf ? can you disable iptapbles and try to connect ? Can you take tcp traces on your ftp server when you try to connect from another server ? can you try ftp localhost ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.