3

I am using glusterfs on several Ubuntu servers: two of them are running glusterfs servers in replication mode.

Without any clear error, the glusterfs partition became stale and the system shows this error when I try to access the stale partition:

Transport endpoint is not connected

Also, when running ls -l on the parent folder I get:

d????????? ? ?      ?          ?                ? myfolder

I tried all types of commands that I can find to umount this partition, but I could not get it done:

umount -l /path/to/mount/point
umount -f /path/to/mount/point

Also, using fuser command to show processes accessing this folder did not work. Unload the fuse kernel module can not be done as it is clear from the kernel config that fuse is built into the kernel and not a loadable module. I found this line in /boot/config-2.6.32-24-server

CONFIG_FUSE_FS=y

I have been left with two options:

  1. Reboot the system.
  2. Create another mount point like myfolder2 and mount this again using sudo glusterfs -f /etc/glustefs/glusterfs.vol /path/to/folder2.

Of course, I have chosen to go with option 2.

Anyone faced such an issue before?

Anyone has a better solution for such a case?

4
  • Did you try fusermount -u /path/to/mount/point?
    – quanta
    Jun 7 '12 at 16:43
  • @quanta: Yes, I did. Same error!
    – Khaled
    Jun 8 '12 at 11:34
  • How about restarting the glusterd process on gluster peer?
    – quanta
    Jun 8 '12 at 15:00
  • @quanta: I see it is accessible and running from other nodes as normal. Do you think it will be useful/enough to restart only one glusterd process or should I restart both processes?
    – Khaled
    Jun 8 '12 at 15:28
2

Try stopping the glusterfs service, first on the second node, then on the first node. For Ubuntu, the command is:

sudo/etc/init.d/glusterfs stop

Alternatively, remove the glusterfs service from startup on both machines and reboot both. The partitions shouldn't mount on boot then, as glusterfs does this job.

1
  • Killing the glusterfs process usually clears this up.
    – mgorven
    Mar 4 '13 at 17:12
2

This works to resolve the 'Transport endpoint is not connected' error with gluster

sudo umount /mnt
sudo fusermount -uz /mnt
sudo mount /mnt
2
  • Some have suggested using fusermount but although GlusterFS is an example of a Filesystem in userspace, sudo fusermount -uz /mnt is not neccessary at all. (-u for unmount and -z for lazy) You can try it, it won't hurt. But in my case, fusermount was not installed. Simply sudu su - to become root, then umount mnt Nov 10 '17 at 12:59
  • @user2219975 I most definitely tried that. If it were so simple, I would have put that as my answer. Not all situations are equal.
    – Tanner
    Nov 13 '17 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.