I installed netatalk on my Ubuntu Server a few weeks ago and configured it so that I could use Timemachine from my mac to backup on a server instead of a external hard drive.

It worked really good until yesterday when I installed Samba to be able to share certain folders on my server to my mac.

Now I receive an error msg:

There are no shares available or you are not allowed to access them on the server. Please contact your system administrator to resolve the problem.

From what I understand is that the problem is on the server and not on my mac. I have tried to restart the computer and without adding any of the folders Samba is sharing adding the timemachine "afp://...@...".

Is there a problem running them both at the same time, do I need to configure samba so that it doesn't reject afp?

I'm pretty new at this...


You can get more info on the issue with the debug log of afpd (Apple Filing Protocol daemon, part of netatalk package). To obtain it, add the following to configuration line in afpd.conf (it's usually located at the bottom of the file):

-setuplog "default log_debug /var/log/afpd.log"

E.g., my config line looks like this:

- -tcp -noddp -mimicmodel TimeCapsule6,106 -uamlist uams_dhx2.so -setuplog "default log_debug /var/log/afpd.log"

After that, restart netatalk service and try to connect to your server from a mac. The /var/log/afpd.log now contain a lot of useful info for resolving the issue. Also, please provide contents of your afpd.conf and AppleVolumes.default (without commented lines, cause there are a lot of it). Mentioned files located in /etc/netatalk, at least in Archlinux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.