When ever I run an Exchange 2010 SP1 Discovery Search I get the following error:

"Search failed as the results link to the target mailbox 'DiscoverySearch@domain.com' couldn't be generated."

  • I have checked to ensure the discovery mailbox is enabled
  • I created a new Discovery mailbox. I get the same error with both Mailboxes.
  • The user account I am using to run the search is a member of the "Discovery Management" security group.
  • I get the same error whether I use the Shell or the ECP to run the search

3 Answers 3


The discovery search mailbox is disabled by default. Enable it, then try your query again.

  • The discovery mailbox is enabled, I have also logged into it and created a folder to be sure.
    – ITGuy24
    Jun 12, 2012 at 15:37

You could try to login to Exchange Management Console and locate the DiscoverySearchMailbox in Recipient Configuration -> Mailbox and assign Manage Full Access Permission for the Domain/Enterprise admins (and domain administrator). Reboot Server and then Run Exchange setup again and test.

If this don't work, you can try to delete the Discovery Search mailbox, then install SP1 again and then recreate the Discovery mailbox, and set the permissions on the mailbox.

  1. re-create the mailbox using: Enable-Mailbox “DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}” -Arbitration

  2. Add permissions to the Discovery Search Mailbox: Add-MailboxPermission -Identity:”mydomain.local/Users/DiscoverySearchMailbox {D919BA05-46A6-415f-80AD-7E09334BB852}” -User:”Discovery Management” -AccessRights:”FullAccess”

I hope this help.


We had the same issue and launched a support issue with Microsoft. In our case the issue was that the external and internal URL of the Exchange Control Panel was not set correctly, the URLs were blank - although the ecp worked, apart from this issue of course.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.