1

I've installed Microsoft iSCSI Software Target 3.3 on a server 2008 R2 machine and created a new iSCSI Target. In the target I created a new Virtual Disk.

From another server I started iSCSI Initiator and in Targets | Target I typed the IP of the Target. (Also tried DNS name.) But when I click Refresh I never see the target. Through googling I found this Youtube tut from a French guy doing pretty much what I did (only difference is I'm in a domain).

I first though that maybe Port 3260 was closed but its not I can telnet to it. Also disabled all firewalls to see if that was blocking anything... No luck so far.

Does anybody know of possible reasons why I can't connect to the iSCSI Target?

If I can provide more info please let me know what's needed? Extra info: I've used this tut to set things up.

4

While googling about connection problems I notices this Article

When you create an iSCSI Target with the Microsoft iSCSI Target software, you create devices and assign them to an iSCSI Target.

The problem is that you need to tell the target which clients are allowed to connect—which by default is no one. Select the properties of the iSCSI target and, under the iSCSI Initiators tab, click Add and select the IQNs of the clients who are allowed to connect. The IQNs of clients that have tried to connect in the past will be displayed, or you can manually type the IQN of the allowed clients. The clients should now be able to connect.

If you're unsure of the IQN of an iSCSI Initiator (the client), launch the iSCSI Initiator Administrator Tool application on the client. Under the Configuration tab, its IQN is shown.

And it explained that the iSCSI initiators tab on the Target should be correct. So I checked my IQN again and yep I fat fingered it! After entering the correct address connection was a fact!

  • As it says in the article Joost linked to, you have to add the iSCSI initiator on the iSCSI target, so the initiator is allowed to connect. – suleimanforever Dec 3 '15 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.