We use Windows Deployment Services on Server 2008 R2 to deploy images to all of our computers. To simplify the process, I put driver packages for display & network in WDS so our techs don't have to install them manually. This worked like a charm up until mid-morning today, when all new images, upon first starting up, while "Starting Services" would launch into "Windows Could Not finish configuring the system. to attempt to resume configuration restart computer". I restarted numerous times, and every time the exact same thing would happen. We'd been able to use this exact same image on the exact same model of computers with no problem. Nothing had changed when we started receiving this error.

After a frantic morning of trying different things, I finally found out that disabling the drivers in WDS would allow it to work exactly as intended, without the error message. My question is, how can I keep the drivers enabled and still have it work. Does anybody have any clue as to what might have caused it to stop working suddenly? There were no errors or signs of trouble up until that error message.

  • While your last line was very polite, taglines, signatures, greetings, "thanks" and other formalities are generally discouraged in questions :) I edited it out for you. – MDMarra Jun 13 '12 at 19:47
  • Personally, Id try using MDT (Microsoft Deployment Toolkit) in combination with WDS. MDT offers you a ton more control, and you can still access it by PXE booting with WDS. (In WDS, instead of using a standard install image, just use a boot image created by MDT) MDT can be configured with total control that allows for picture perfect deployments to every hardware type you can find drivers for. For instance, I just built an image on a Dell Precision T3500 (quad core Xeon developer desktop) I then turned around and built, using the same image, a Latitude E6500. – user78214 Jun 13 '12 at 20:06
  • While MDT sounds promising, we've tried it in the past and without a full SCCM setup, it tends to cause more problems than it solves, at least in our network. – bjschafer Jun 14 '12 at 12:47
  • I'm not sure what version you tested, but MDT 2012 was just released. Check out the 'What's new in MDT Guide' on this download page. And remember, MDT can be a stand alone product, so you can experiment without interfering with your WDS setup. Using selection profiles and sorting your drivers by model in the driver store can be quite helpful with the problem you just had. – dwolters Jun 14 '12 at 19:25

Chances are that, while the machines might be the same model number, there is a slight hardware change under the hood. Perhaps a different revision of video card, NIC, whatever.

I'd check on the vendor's website for updated versions of the drivers and replace the existing ones with the new drivers. If that doesn't work, load them back one at a time until you've isolated the culprit and open a ticket with the vendor.

  • That was it, thank you. I removed all the drivers and start added them back one at a time, and thus far I've run into no problems. – bjschafer Jun 14 '12 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.