1

I'm trying to run virtual env and all the documentation says I don't need to run it as root (and probably shouldn't). If I run it as root, everything works. If I run it without root, I get:

[stats@crunch ~]$ virtualenv env
Traceback (most recent call last):
  File "/usr/bin/virtualenv", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: virtualenv==1.7.1.2

I believe I can change the ownership and it's the same difference, but I'd like to know why this is happening. It's a fresh CentOS 6.2 installation.

1

easy_install had installed virtualenv without read permissions for group or world (only execute). Any idea why that happens?

Doing chmod -R 755 on the /usr/lib/python/site-packages/virtualenv directory resolved the issue.

0

See this answer on stack overflow, you probably need to look at environmental variables and write permissions.

0

I had exactly the same error msg. You have to create "env" directory before executing virtualenv

mkdir env
virtualenv env
2
  • You should not have to pre-create the directory used by virtualenv. The need to do so indicates that something is wrong with your installation.
    – larsks
    Aug 13 '12 at 1:25
  • I wish someone could come up with a perfect solution. At the moment, this works for me.
    – Xiong
    Aug 13 '12 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.