I have a Windows Server 2008 SP 2 Task Scheduler task that should run every 10 minutes.

enter image description here

The trigger says "At 6:50 PM every day - After triggered, repeat every 10 minutes indefinitively."

Looking at the Next Run Time, it says 6/18/2012 8:00 PM. However, when I let that time pass, the Next Run Time just changes to 8:10 PM but the task has not started and the Last Run Time is unchanged from yesterday. Last Run Result is "The operation completed successfully. (0x0)".

It worked when I first created it a few days ago, but today I disabled then re-enabled it and now it just won't start automatically. I can still manually trigger it and that works.

How can I get this task to automatically run every 10 minutes when enabled no matter what?

  • How do you know that the task has not run at that interval? Often a task that runs fine from a command prompt will not work from a scheduled task because of one of many different reasons. Credentials that don't have permissions, or no credentials at all, or no "start in" path, or relative paths being used when they shouldn't, etc. Point is, maybe the task is starting, but is also ending immediately. Jun 19, 2012 at 3:14
  • The task has executed in the past fine as indicated in the History tab of TS. I just noticed the issue today when I disabled the task then re-enabled it. Looking at the History tab, it's no longer starting at the time indicated in the Next Run Time. I keep refreshing the view and the Next Run Time just updates to 10 minutes later but nothing happened (Last Run Time and Last Run Result are not updated).
    – Dan C
    Jun 19, 2012 at 3:41
  • 2
    I rebooted the server and, what do you know, the tasks are working now! Looks like Task Scheduler needed a good kick in the pants. I will keep an eye and update here.
    – Dan C
    Jun 19, 2012 at 19:16
  • 1
    This may be just me---but I experienced it when I changed ... wait for it... the password on my desktop. I don't know if this is a known bug. But this is the second time that I'm Googling this without realizing what happened, so I thought I'd leave a note.
    – Kim
    Oct 6, 2020 at 4:41
  • 2
    setting start date solved the problem for me for now. I guess the workaround is: after disable/enable update the start date. weird! Apr 12, 2021 at 9:42

11 Answers 11


My fix was simple... I had already manually ran the scheduled task, but I created the scheduled task for the intent of using it daily... I had several TB to copy over to a backup server so I could not schedule the task just yet. My fix was to update the Start date to the current day, and that for some reason resolved it. Detailed info: Previous start date was Jan 3 which was when I created the task and manually ran it. The task was enabled to run daily and failed on Jan 5th. Went into the settings and updated the date to the current day (Jan 6), ran that night and completed on Jan 7). Location: Server 2012 R2, Task Scheduler, Open task, Triggers Tab, Open Trigger, Update Start Date to current day.

Hope this helps others.

  • This worked for me too. I imported an older Task from another Computer, the Start Date was set to the year 2010. After updating it to today, it worked like a charm! Dec 26, 2016 at 15:31
  • 1
    I set my task to be in the upcoming future and that fixed it for me. The current day wasn't enough if it was in the past.
    – jocull
    Sep 14, 2017 at 21:12
  • Great, imported scripts from another server, because there were many triggers installed. They were even from the same day! But I had to manually open each trigger and save it again to active it. Stupid MS! Jan 11, 2018 at 19:34
  • 2
    I have seen this on newer versions of Windows also. It is a bug, no? Sep 13, 2018 at 1:47
  • Tried that, didn't work for me.
    – Lucas925
    Dec 4, 2020 at 13:28

This may not be relevant now, but in case you enable\disable scheduled task(s) manually you can use an option of starting the task asap after the scheduled start was missed. enter image description here


I'm late to the party, but for anybody suffering from the same problem :

When using a Daily schedule and the Repeat task every: option in the trigger's Advanced Settings, do not use Indefinitely in the for a duration of: option. Change it to 1 day

This does not make any sense but solves your problem. Windows 2016 still has this problem.

  • 1
    This is insane! It works! I was trying everything on the internet without luck before this. Trying to get powershell script working. It was running fine when manually hitting "run" but not as scheduled.
    – Henri
    Dec 14, 2021 at 20:20
  • It works on Windows Server 2019, thanks!!! For a task created with a trigger to run at some time every day (for example 5:00 am) and after triggered repeat every x minutes indefinitely. If trigger's start date is in the past, such task will not start once created and will not start after server's reboot until that trigger's time - 5:00 am in example above. Setting duration to 1 day resolves the issue - task starts at a proper time intervals once created and after reboot. Checkbox 'Run task as soon as possible after a scheduled start is missed' doesn't affect and could be unchecked May 11 at 2:31
  • Yep, that was it. Still today. Oct 13 at 16:53
  • Thanks for this fix it worked for me windows 11 Nov 20 at 7:27

Probably too late to be any help on this 3-year old topic.

On the General tab make sure you choose the "Run whether user is logged on or not" option.

The default setting is "Run only when user is logged on" which means the task will not run until someone logged on to the server.

  • I run into this situation, so I started looking at the Event Viewer for any entry with "Task Scheduler" as Source to see if it could give me any clue and I dit found nothing. But if you look into the History tab of the Task Scheduler for the given task you will find a warning for each time the task did not execute for this reason.
    – rortegax2
    Jan 9, 2020 at 8:56

Check the job start date/time. This can trip you up (it has snagged me before).

  • 1
    The job is set to Start 6/13/2010, 6:50 PM. Since today is the 18th, I don't think that's the issue.
    – Dan C
    Jun 19, 2012 at 4:58
  • At least I hope that's not the issue. I would hate to have to change the date and time every time I disable/reenable the task. I didn't have to do that in Windows Server 2003 Task Scheduler.
    – Dan C
    Jun 19, 2012 at 5:20

I had similar issue. The task scheduler stopped working due to some reason at remote location. but when the machine restarted task scheduler did started. I told them to run the task scheduler job and then I hope it would pick up the next run, nut it didnt start. The only last thing is I have to go to the server location, then change the start date from old date to current date and also change the time ahead to current time, after this change only it start working. However, I thought it should start by itself when the machine restarts. I could nt found any setting that worked except to manually and change the date time to current and next ticking time.


I think you want to set the task to run once every 10 minutes for 24 hours as you are triggering it to repeat once daily. so it would run daily, repeating every 10 minutes for 24 hours and then repeating the process.

screen cap from task scheduler

Might also need to set the "Stop task if it runs longer than" option under "Settings" for the task. Might be skipping the scheduled task because task scheduler thinks the task is still running when it is not...


Make sure both the task and the trigger are enabled.

I came here because I had the same problem. Turns out, the trigger was disabled. For some reason task scheduler uses disabled triggers in the "Next Run Time" box...

  • My trigger was deactivated, too. Why this is remains a mystery, as the task was running fine every 5 minutes until a few hours ago. Definitely noone has messed with the task at that time.
    – Thomas
    Aug 3, 2020 at 19:28

Do you have Windows Live installed? I was pulling my hair out over this, but then found if you disable the Windows Live \ SOXE task everything comes back to life



It's a Windows bug in Task Scheduler

I setup a task to fire every 15 minutes similar, however, it got stuck in "Task has not run yet" state even though the next run time was updating correctly

After approximately a day it started working as expected


CHECK the CONDITIONS tab under POWER: if you are plugged in or not...it is causing a different treatment!

Not sure if this is still helpful, but I had the same issue and was looking for a solution a couple of hours.

Before it worked on a server and now I was trying to do something on my own windows environment. But this was not why it first worked and after not anymore.

The difference was that my computer was plugged in before and now it wasn't. UNCHECK the box 'Start the task only if the computer is on AC power'.

  • wow - spent so long tearing my hair out as to why my task isn't starting and I'm sat here without my laptop plugged in. So obscure and easy to miss!
    – SE1986
    Nov 17, 2020 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .