20

I have a Windows Server 2008 SP 2 Task Scheduler task that should run every 10 minutes.

enter image description here

The trigger says "At 6:50 PM every day - After triggered, repeat every 10 minutes indefinitively."

Looking at the Next Run Time, it says 6/18/2012 8:00 PM. However, when I let that time pass, the Next Run Time just changes to 8:10 PM but the task has not started and the Last Run Time is unchanged from yesterday. Last Run Result is "The operation completed successfully. (0x0)".

It worked when I first created it a few days ago, but today I disabled then re-enabled it and now it just won't start automatically. I can still manually trigger it and that works.

How can I get this task to automatically run every 10 minutes when enabled no matter what?

  • How do you know that the task has not run at that interval? Often a task that runs fine from a command prompt will not work from a scheduled task because of one of many different reasons. Credentials that don't have permissions, or no credentials at all, or no "start in" path, or relative paths being used when they shouldn't, etc. Point is, maybe the task is starting, but is also ending immediately. – Mark Henderson Jun 19 '12 at 3:14
  • The task has executed in the past fine as indicated in the History tab of TS. I just noticed the issue today when I disabled the task then re-enabled it. Looking at the History tab, it's no longer starting at the time indicated in the Next Run Time. I keep refreshing the view and the Next Run Time just updates to 10 minutes later but nothing happened (Last Run Time and Last Run Result are not updated). – Dan C Jun 19 '12 at 3:41
  • I rebooted the server and, what do you know, the tasks are working now! Looks like Task Scheduler needed a good kick in the pants. I will keep an eye and update here. – Dan C Jun 19 '12 at 19:16
14

My fix was simple... I had already manually ran the scheduled task, but I created the scheduled task for the intent of using it daily... I had several TB to copy over to a backup server so I could not schedule the task just yet. My fix was to update the Start date to the current day, and that for some reason resolved it. Detailed info: Previous start date was Jan 3 which was when I created the task and manually ran it. The task was enabled to run daily and failed on Jan 5th. Went into the settings and updated the date to the current day (Jan 6), ran that night and completed on Jan 7). Location: Server 2012 R2, Task Scheduler, Open task, Triggers Tab, Open Trigger, Update Start Date to current day.

Hope this helps others.

  • This worked for me too. I imported an older Task from another Computer, the Start Date was set to the year 2010. After updating it to today, it worked like a charm! – Stefan Profanter Dec 26 '16 at 15:31
  • I set my task to be in the upcoming future and that fixed it for me. The current day wasn't enough if it was in the past. – jocull Sep 14 '17 at 21:12
  • Great, imported scripts from another server, because there were many triggers installed. They were even from the same day! But I had to manually open each trigger and save it again to active it. Stupid MS! – Hugo Delsing Jan 11 '18 at 19:34
  • 1
    I have seen this on newer versions of Windows also. It is a bug, no? – samsmith Sep 13 '18 at 1:47
8

This may not be relevant now, but in case you enable\disable scheduled task(s) manually you can use an option of starting the task asap after the scheduled start was missed. enter image description here

7

Check the job start date/time. This can trip you up (it has snagged me before).

  • 1
    The job is set to Start 6/13/2010, 6:50 PM. Since today is the 18th, I don't think that's the issue. – Dan C Jun 19 '12 at 4:58
  • At least I hope that's not the issue. I would hate to have to change the date and time every time I disable/reenable the task. I didn't have to do that in Windows Server 2003 Task Scheduler. – Dan C Jun 19 '12 at 5:20
7

Probably too late to be any help on this 3-year old topic.

On the General tab make sure you choose the "Run whether user is logged on or not" option.

The default setting is "Run only when user is logged on" which means the task will not run until someone logged on to the server.

3

I think you want to set the task to run once every 10 minutes for 24 hours as you are triggering it to repeat once daily. so it would run daily, repeating every 10 minutes for 24 hours and then repeating the process.

screen cap from task scheduler

Might also need to set the "Stop task if it runs longer than" option under "Settings" for the task. Might be skipping the scheduled task because task scheduler thinks the task is still running when it is not...

2

I had similar issue. The task scheduler stopped working due to some reason at remote location. but when the machine restarted task scheduler did started. I told them to run the task scheduler job and then I hope it would pick up the next run, nut it didnt start. The only last thing is I have to go to the server location, then change the start date from old date to current date and also change the time ahead to current time, after this change only it start working. However, I thought it should start by itself when the machine restarts. I could nt found any setting that worked except to manually and change the date time to current and next ticking time.

1

Do you have Windows Live installed? I was pulling my hair out over this, but then found if you disable the Windows Live \ SOXE task everything comes back to life

http://social.msdn.microsoft.com/Forums/en/winserver2008appcompatabilityandcertification/thread/6fa3c7fa-511b-498d-9b37-1201e1ff2e59

1

Make sure both the task and the trigger are enabled.

I came here because I had the same problem. Turns out, the trigger was disabled. For some reason task scheduler uses disabled triggers in the "Next Run Time" box...

0

It's a Windows bug in Task Scheduler

I setup a task to fire every 15 minutes similar, however, it got stuck in "Task has not run yet" state even though the next run time was updating correctly

After approximately a day it started working as expected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.