0

I'm trying to setup Apache to use a self signed certificate but I can't seem to get it working. I've tried many methods and last tried This answer but still ran into the same issue. Safari (And Chrome) give me a completely different certificate (Not even close to the one I provide it) that makes no sense at all. I haven't heard of anyone else having this issue nor do I know where it's getting "ORname_Jungo: OpenRG Products Group" from. I also posted my ssl configuration here.

Does anyone have any ideas?

Here's

  • How did you generate the certificate? – pjc50 Jun 19 '12 at 14:02
  • I generated it with openssl req -new -x509 -days 999 -nodes -out apache.pem -keyout apache.pem – nosedive25 Jun 19 '12 at 15:14
  • where id apache come from? what OS / distro? Do you use jungo.com/openrg/pr_openrg.html? – Ram Jun 19 '12 at 17:53
1

So I figured out what caused this. First off the "server" is a test machine I'm running within my home network that I use to test things before pushing them to the real server. I realized that I had forgotten to forward port 443 for https, thus sending the request to my router, not my server so it was returning my routers ssl certificate (Which I was unaware it even had). After forwarding the port all is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.