1

I have a PC with Windows Home edition and a machine running Windows Server 2008 R2 in a domain. Anytime I connect to its shared folders I get prompted for a username and password. How can I set a policy in Active Directory for that server not to ask for username and password?

| improve this question | | | | |
4

The versions of Windows that aren't earmarked "Professional" cannot join a Windows Active Directory domain, but you can cheat and do what's sometimes referred to as the "poor man's domain trust". Basically, you create an account in the Active Directory domain that matches the username / password used on the non-Domain-joined PC. Once you've done this, access to domain resources from the non-Domain-joined PC will work as though the PC is domain-joined, because the PC is authenticating with a username / password that ends up being valid in the domain.

This is preferable to enabling the Guest account because it doesn't open up access to unauthenticated users.

| improve this answer | | | | |
0

To do what you want you will have to enable the "Guest" account on the computer hosting the files and then grant the "Everyone" group whatever access you want.

"Guest" is a user account, but its enabled / disabled status is interpreted by the operating system as a boolean "Allow unauthenticated users to connect?"

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.