1

I just received today my dedi server access, I installed apache:

yum install httpd

After it, I configured httpd.conf located in /etc/httpd/conf, I modified server name, added server IP, and my email.

Perl was installed already, when I type perl -v I get:

This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

I installed mod_perl:

yum install mod_perl

I edited again /etc/httpd/conf/httpd.conf, and I added:

AddHandler cgi-script .cgi .pl
Options +ExecCGI

to:

<Directory "/var/www/cgi-bin">
    AddHandler cgi-script .cgi .pl
    Options +ExecCGI
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

I uploaded via sFTP a hello world cgi file to /var/www/cgi-bin, when I browse the file I get Internal Server Error. I already gave the file 755 chmod

Hello world file:

#!/usr/bin/perl
print("Content-type:text/html\n\nHello World!");

URL to test: http://78.138.126.87/cgi-bin/test.cgi

Please HELP!

  • 2
  • @user993553 you should submit that as an answer, not just a comment; it looks promising to me. – pjmorse Jun 19 '12 at 18:45
  • it's working now thanks, please submit it as answer to mark it as valid answer – Hamza Jun 19 '12 at 18:48
1

see http://www.centos.org/docs/4/4.5/Reference_Guide/s3-httpd-v2-mig-mod-perl.html

0

Based upon your configuration it sure looks like you're trying to run your perl script from the perl cgi binary, not mod_perl, which is not what you seem to think it is.

What does your error log say? It would be most helpful if you posted that. I'm betting that ExecCGI is disabled further up the tree.

  • Fixed, I added the script Alias in perl.conf, restarted apache, and the test worked – Hamza Jun 20 '12 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.