We have a server in the office running Windows Server 2003

Our office is connected to our datacenter via hardware VPN (Linksys RV082 router in the office to CISCO router in the datacenter).

There is a job (PowerShell script) that runs on the server in the office that does following: ZIP certain files from the server using 7Zip, copy ZIP file to a network share in the office and verify ZIP integrity, copy ZIP file to a network share in the data center and verify ZIP integrity.

Problem is - verifying ZIP integrity for the file in the data center always fails. However, if I run 7Zip on the server in data center that exposes that share ZIP file verifies just fine, so it is not actually corrupted during copy operation.

Additionally, I tried running ZIP on other computers in the office to verify ZIP file on datacenter file share and it verifies OK.

I tried plugging server to the same network port where my workstation is connected using different cable (my workstation doesn't exhibit this problem) and ZIP verification still fails.

In summary, there is one server (the local server on which the script runs) on which the verify always fails when performed across the WAN. But the verify always succeeds when run from other computers in the same site as the server.

On network adapter properties for the server in question there is no "Advanced" tab where one can usually configure a lot of network settings.

Network card driver is up to date (Windows Update doesn't find anything newer and Lenovo website doesn't have any drivers for Windows 2003 for this computer model).

Is there any other way to configure network setting via command line? What settings could be relevant to this problem?

  • 2
    have you hashed the files to see if they are different? – longneck Jun 20 '12 at 15:33
  • I just tried that. If I run fciv.exe (Microsoft utility to compute/compare hashes) on local file from server in the office and then on datacenter file from server in the office hashes don't match. However if I run fciv.exe on datacenter in the office hashes match – Joe Schmoe Jun 20 '12 at 15:59
  • ServerFault doesn't let me edit my comment after 5 min. Last sentence in previous comment should read: However if I run fciv.exe on datacenter server hashes match – Joe Schmoe Jun 20 '12 at 16:07
  • So you have a network card that's apparently unsupported and want some way to change driver specific settings? – Jim B Jun 20 '12 at 17:10
  • Well this computer is a workstation, not a server. So it is not surprising Lenovo has no drivers for Windows Server 2003. However, when OS was installed it recognized network adapter and installed drive automatically. Other than this issue we experience no problems with it. – Joe Schmoe Jun 20 '12 at 17:32

So it appears this one server (Server A) verifies the file successfully when it is local but fails the verification over the WAN, but other workstations can successfully verify the remote file.

Some things to check:

  1. Is 7zip the exact same version on all machines?
  2. Run sfc /scannow on Server A and see if it fixes anything. You may have a problem with your TCP stack on that particular box.
| improve this answer | |
  • Yes, you understood this correctly. 7Zip is the same version, I also tried Winzip - same problem and Winzip also verifies fine from other computers in the office, just like 7zip. I also tried FCIV.exe (hash calculator/verifies from Microsoft) - same problem (see my another comment above). I will look into using SFC utility. – Joe Schmoe Jun 20 '12 at 16:00

I hope someone else will find it useful: I never got 7-Zip work successfully via this connection, so I ended up having to implement PowerShell remoting to spawn 7-Zip on the remote server.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.