IIS 7.5:
Ftp Firewall Suport: Data Ranges 49152-65535 using external Ip of Amazon EC2 static IP
Ftp IPv4 Restriction: allow: Amazon EC2 static IP
Ftp Authentication: Anonymous: Enabled, Basic: Disabled, IISMgr: Enabled
Ftp Authorization: Allow All Users: Read/Write

Windows Firewall (Inbound):
Open port 21
Open port ranges: 49152-65535
Open port: 20

Amazon EC2 Security Group:
Custom TCP Rule: 21
Custom TCP Rule: 49152-65535

It works on Internet Explorer when I typed the address: ftp://localhost on the server but when I entered the Amazon EC2 Static IP (ftp://IPADRESS) it doesnt connect.

I cant connect also to FileZilla

I tried to turn off the firewall completely and it works. Aside from EC2 Security Group and Windows Inbound Rules is there anything that may block the connection?

  • Did you permit the requisite ports in one of the security groups applied to this instance? – EEAA Jun 22 '12 at 4:04
  • Yes. Port 21 and Port range 49152-65535 – h3n Jun 22 '12 at 4:51

I had a similar problem with accessing IIS.

I solved it by:

  • Looking at my instance properties and finding the security group
  • Adding HTTP and HTTPS to the security Group, Apply, and Apply Rule Set
  • Use the machine name to connect to the instance. The IP did not work for me - but I do not have a static IP assigned.

Works like a charm and very fast. :)

| improve this answer | |
  • 1
    My passive FTP started working when I used the AWS domain/Url thing instead of the IP address. But my FTP client is still saying 'Server sent passive reply with unroutable address. Using server address instead.' – Ian Warburton Oct 8 '12 at 4:10

You can keep 2008 R2 default FTP fw rules so you dont need to actually add a new ones. The default rules are OK. If you cannot connect, you should kill that process via task manager and wait 5 sec for it to restart. In task manager select services tab, look up the FTPSVC, right click, go to processes, then end process svchost.exe and this is it. This is an undisclosed Windows bug which can be also worked around by rebooting the server. It is related to both firewall settings, the output and input firewall, and ftp configuration change and IIS server reloading, thus a bit complex to address considering the security measures as well the user from which the FTP service is run.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.