I have vmware vsphere 4 esx4.1. I have a virtual machine with centos6 64bit OS and 3 virtual disks (50GO system/ 250 GO user data / 250 GO backup)

When I tried to take a snapshot of the VM, I got an error message like unspecifi-ed filename has bigger size than biggest size authorized by the datastore.

My problem is that the VM could not start after I got this message error because it could not get access to the 2nd and 3rd disk (only the system disk is normal). It seems that these 2 disks are locked.

I restart the physical esx machine but I had the same thing!

Could you please help! I'm realy blocked and I need your help!


When I've encountered similar situations, I've shut the virtual machine down and navigated to the datastore containing the VM. I use NFS for most datastores, so there are lock (.lck) files that can be removed. Easy.

However, I'm assuming you're using VMFS on local storage. The process is less-transparent. VMWare has a knowledge base article outlining the troubleshooting steps for locked VM files. Enable SSH access to the host if you can.

These virtual machine files are commonly locked for runtime:


Since this issue occurred during a snapshot, you'll want to focus on the <DISKNAME>-flat.vmdk and <DISKNAME>-<ITERATION>-delta.vmdk files. Either way, follow the steps listed in the VMWare article.

  • Thank you for your answer. I tried to follow this link but I didn't find any locked disk! Could the snapshot makes the disk irreadable? In the VM I made fdisk -l and it says that it has not a valid partition table! – user125786 Jun 23 '12 at 17:54
  • Were there any "delta" files in your datastore? What errors are you getting in the vSphere client console? – ewwhite Jun 23 '12 at 17:57
  • there are no any *delta files. It was the first time that I made a snapshot for this virtual machine – user125786 Jun 23 '12 at 18:01
  • in the vspehere client there is no error! The VM runs until mounting the 2nd and 3dr disk! I have this message in the Centos Os VM: << fsck.ext3 : Périphérique ou ressource occupée lors de la tentative d'ouverture de /dev/sdb1 Système de fichier monté ou ouvert en mode exclusive par un autre programme? >> I could login in into the VM, but the 2nd and 3rd disk are not seem by the OS. – user125786 Jun 23 '12 at 18:11
  • Now, I have this error when I start a VM : Motif : The destination file system does not support large files. Impossible d’ouvrir le disque '/vmfs/volumes/4f9d56ed-dfb9f20e-00e3-d4ae52734324/hosting/hosting_1.vmdk' ou l’un des disques snapshot dont il dépend. – user125786 Jun 23 '12 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.