I created a vlan on Ubuntu with vconfig tool with 21 as id and eth1 as the host port. I connected eth1 to one of the ports on the swtich (GE23) as all ports trunk by default. In the webgui I created a vlan named test with the id 21 and I made GE2 are port as an access port. In port to vlan mapping I selected vlan 21 and added it port GE2 by selecting untagged option. I have assigned as the ip of eth1.21 on Ubuntu. If I connect another cleint pc to GE2 port with a ip of I cannot ping the server ip ( Ping from server to client also does not work. I inspected packets that are sent out eth1 on the server and I could see the vlan 21 tag. And I connect the other end of the cable to a different Linux pc and inspected the packets but no vlan tags can be seen. What could be preventing me from getting vlans working?

Edit 1 screenshots:

Interface Settings

Port to vlan mapping

Port to vlan membership

  • when you ping from the ubuntu to the PC, do you see the Ubuntu's ARP frames on GE2 with wireshark? Vlan access ports can't use a vlan tag – Mike Pennington Jun 28 '12 at 11:37
  • No Ubuntu arp frames come out of GE2. – nixnotwin Jun 28 '12 at 14:20
  • Then one of the ports is in the wrong vlan, or one port has no physical link. – Mike Pennington Jun 28 '12 at 14:21
  • 2
    That default trunking on the switch is known to be problematic. It actually tries to negotiate whether to trunk or not and that usually only works properly if the other end also does negotiation. I would recommend to explicitly set GE23 to dot1q mode. – Tonny Jun 28 '12 at 15:27
  • 1
    If you upgrade to the latest firmware ( you now get SSH and SNMP access on these switches. In my case, I had to set the "SmartPort" feature to Static and "Switch", to make it work with my ESXi hosts. – alex9183 Jun 14 '13 at 2:55

After my initial comments and Mike's suggestion (see above) I did a bit of fact checking. (I was going from memory.) We have several dozen of SG200 switches lying around here. They have been causing issues in the past.

We found the following:
- Upgrade the SG200 to the latest firmware.
- For any port on the switch that you need to have as Trunk: Set it to Access and then back to Trunk.
Even though the web-gui shows "Trunk" the port will initially (or after factory-default reset) be in "General".
This is an auto-negotiate mode that often only works properly if the other end of the connection is also a Cisco switch in "General" mode. The setting to Access and then back to Trunk will insure it is really working as Trunk.

Disabling spanning-tree (STP) on the port is in this case probably also a good idea as the server is certainly not going to participate in STP elections.

  • I did everything you said but still no success. – nixnotwin Jun 29 '12 at 15:16
  • 1
    Are you sure the vlan 21 is not excluded on port GE23 ? Some switches require the vlan to be enabled on the port, even if it is a trunk. Your 2nd screenshot shows 21 as not-enabled on the other trunks. (But it doesn't show the status of GE23.) – Tonny Jun 29 '12 at 22:36
  • Yes. It worked now. Even if I'd posted a partial screenshot, still you were able to imagine my issue and suggest a solution. In the port to vlan mapping page I selected access port (GE2) as untagged and the trunk port (GE23) as "tagged" and everything started to work. – nixnotwin Jun 30 '12 at 10:55
  • 1
    :-) I had a similar situation myself a few weeks ago with HP ProCurve switches. They have similar behavior. If it hadn't been for that I probably wouldn't have thought about it either. – Tonny Jun 30 '12 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.