1

I'm trying to copy a backup I've made from one server to another using either an SSIS or Powershell step in a job. I've run into the same error on both systems when running the step under the sql agent. I receive errors that the path does not exist. I've tried granting the agent rights to e:\backups, where the file is located, but it still doesn't work.

When I use a proxy for the step, it works fine.

Can anyone help me with what permissions to grant to sqlagent?

Rights look to have been granted to MSSQL$Instance1 on the backup drive.

  • Granted SQLAgent$Instance1 full rights to the e:\backups folder and still no dice. – Sam Jun 28 '12 at 22:01
0

Given that you indicate you are copying to E:\Backups that it represents another server, it sounds like you are using mapped drives. Whatever agent you are using is probably being run in non-interactive logon mode, which precludes the use of mapped drives. I suggest you try to use UNC paths instead, ex: \\servername\backups

  • Yes, I didn't specify, but I am using UNC paths. – Sam Jul 10 '12 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.