3

I recently downloaded SmartOS and tried running it on my HP ProLiant N40L, but it always fails on boot.

After dd'ing the image to the USB stick, I plug it into the internal USB header and turn the machine on. After selecting from GRUB, it displays the following:

, bss=0x0

It sits there for 2-4 minutes, then finally boots the OS and displays the following:

WARNING: Couldn't read ACPI SRAT table from BIOS. lgrp support will be limited to one group.

SunOS Release 5.11 Version joyent_20120614T184600Z 64-bit Copyright (c) 2010-2012, Joyent Inc. All rights reserved. WARNING: kvm: no hardware support

After that, it just sits there. I've left it for 24 hours and it never progressed beyond this point. If I press the power button, it does respond:

WARNING: Power off requested from power button or SC, powering down the system!

Then after 30 seconds:

WARNING: Failed to shut down the system!

I've tried this with two different USB sticks.

I've seen some mentions on the SmartOS website about people running it on an N40L, booting from USB, so maybe it's just broken hardware? Has anyone gotten this working?

  • This has been fixed since the 2012/08/09 release (smartos-20120809T221258Z-usb.img.bz2). Thanks to jperkin. – dyu Aug 10 '12 at 16:39
2

This is a bug somewhere in the IPMI driver imported from FreeBSD back in April. If you edit the GRUB boot arguments and add:

-B disable-ipmi=true

then it will boot fine (though the bss=0x0 hang will remain).

| improve this answer | |
0

As mentioned here the message about ACPI SRAT is just a warning.

For me, boot hangs if there is no (cabled) network. I install on a HP Pavilion and it boots if it has ethernet. The wifi card is up but not suitable or seen at all by SmartOS.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.