2

I'm using Ubuntu Server, and this is what my /etc/network/interfaces looks like:

auto wlan0
iface wlan0 inet static
     address 192.168.1.68
     netmask 255.255.255.0
     gateway 192.168.1.254

and it gives me this error when I try to do sudo ifup wlan0

RTNETLINK answers: File exists
Failed to bring up wlan0
2
  • Has anybody solved this problem?? I am stuck for the last two days in this... :( please help...
    – user157096
    Feb 1, 2013 at 8:55
  • try ip route show or something like this. read man ip for further informations.
    – user209064
    Feb 12, 2014 at 10:31

2 Answers 2

5

That message usually means that the route being added already exists.

  1. Run sudo ifdown wlan0 and sudo ifconfig wlan0 down (these will probably output errors, just continue).
  2. Then check the output of ip route for any routes related to wlan0. If there are any use sudo ip route del to remove them (for example, sudo ip route del 192.168.1.0/24 dev wlan0).
  3. Try sudo ifup wlan0 again.
6
  • sudo ifdown wlan0 gave me the error: interface wlan0 not configured. Jul 2, 2012 at 5:43
  • @IsaiahBugarin Yes, it will give errors. Now check the routes and then try bringing it up again.
    – mgorven
    Jul 2, 2012 at 5:44
  • That command gave me 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.68. ifup gave me same error still. Jul 2, 2012 at 5:54
  • @IsaiahBugarin Edited.
    – mgorven
    Jul 2, 2012 at 6:05
  • sudo ifdown wlan0 output error, the other one did not. ip route didn't output anything. sudo ifup wlan0 gave error. Jul 2, 2012 at 6:13
-3

Try setting gateway 192.168.1.1. It is a default value of most Wifi routers. This helped me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.