I'm running this linux:

Linux host.themepark.com 2.6.32-220.4.1.el6.x86_64 #1 SMP Tue Jan 24 02:13:44 GMT 2012 x86_64 x86_64 x86_64 GNU/Linux

And I run the Selenium stand-alone server on my box with this command:

java -jar /home/l/cron/selenium-server-standalone-2.24.1.jar > /logs/selenium.log 2>&1 &

Here's the problem: as soon as I do that, the server load starts skyrocketing. I even went back and downloaded older versions of the Selenium server, but same results with 2.23.1, 2.23.0, and 2.19.0.

Note that the server load starts going nuts before I issue ANY commands to Selenium or do anything else. All I'm doing is firing up the server, per the command above.

This used to work perfectly on my server without causing massive server load, so something has changed, but I'm not sure what. My server is a managed VPS so I don't know if there is some kind of auto-update script that kicked in or what... but it's a problem.

(Incidentally, even though the server load climbs like crazy, everything still works: after firing up Selenium, my server creates a screen with Xvfb so Firefox will be happy, then a PHP script talks to Selenium to do what it needs to do before shutting everything down. It takes a LONG time, and the load gets all the way up to 8 [!!!] before it is finished, which kills my web server and makes the main site horribly unresponsive... but it does get everything done.)

Any suggestions for what is going on, why it's started doing this and/or, most importantly, how I can make Selenium not kill the server when it starts up... would be GREATLY appreciated!


if this started recently (last saturday...?) you could be affected by the leap second bug

try running as root:

date; date `date +"%m%d%H%M%C%y.%S"`; date;

and see if this fixes your load problem

  • Thanks. I tried that and it output the same date + time three times in a row (all 3 identical)... and now problem solved! Crazy! But THANKS! So what did those 'date' commands do? Set the date forward by one second? – Eric Jul 3 '12 at 16:22
  • 1
    was all over the (IT-)news... . tons of linux servers went to 100% cpu, mostly java processes (but also some instances of mysql and other services) were affected. setting the date again fixes the issue. (that is what the above commands do) google for "leap second bug" if you want the technical details :) – Gryphius Jul 3 '12 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.